This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1266867 - Help! What is a Smart variable?" points to an invalid page in Satellite 6.1 GUI
Help! What is a Smart variable?" points to an invalid page in Satellite 6.1 GUI
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Branding (Show other bugs)
6.1.2
x86_64 Linux
low Severity low (vote)
: Beta
: --
Assigned To: Shimon Shtein
Kedar Bidarkar
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-28 05:45 EDT by rakesh kumar
Modified: 2016-07-27 07:07 EDT (History)
6 users (show)

See Also:
Fixed In Version: rubygem-foreman_theme_satellite-0.1.4-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:07:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rakesh kumar 2015-09-28 05:45:16 EDT
Description of problem: When editing a Puppet Class, on the Smart Variable tab, the URL mentioned in t
"Help! What is a Smart variable?" points to an invalid page.

https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/User_Guide/Configuring_Smart_Parameters.html

This page does not exist and return a 404


Version-Release number of selected component (if applicable):Red Hat Satellite 6.1


How reproducible:Always


Steps to Reproduce:
1.Login to Satellite GUI with admin rights.
2.Click on Configure > Puppet Classes > Click on any Class name > click on Smart Variable .
3.Under smart variable tab, there is one hyperlink for "What is a Smart Variable". When we click on Smart variable to open the link , it will show 
"This page does not exist and return a 404" error.

Actual results: This page does not exist and return a 404


Expected results: Smart Variable hyper link should point to valid URL-
"https://access.redhat.com/documentation/en-US/Red_Hat_Satellite/6.1/html/User_Guide/sect-Red_Hat_Satellite-User_Guide-Configuring_the_Provisioning_Environment-Parameters.html#sect-Red_Hat_Satellite-User_Guide-Configuring_Smart_Parameters"



Additional info:
Comment 4 Kedar Bidarkar 2016-04-07 02:27:14 EDT
There is no such thing anymore as "Help! What is a Smart variable", also the Documentation links in the smart variable tab now point to the puppet-class edit page, which needs to be fixed.
Comment 5 Shimon Shtein 2016-04-07 07:55:15 EDT
Checked with snap 6.2, and it redirects to a valid documentation link.
Comment 6 Kedar Bidarkar 2016-04-18 11:00:47 EDT
VERIFIED with sat62-snap8.1

Ok, we  do not have "Help! What is a Smart variable" , but rather we have a "Documentation" button in the UI, which takes us to the desired link.
Comment 7 Bryan Kearney 2016-07-27 07:07:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.