Bug 1266874 - gdeploy: rebalance fails with volume in start state
gdeploy: rebalance fails with volume in start state
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: gdeploy (Show other bugs)
3.1
Unspecified Unspecified
unspecified Severity high
: ---
: RHGS 3.1.3
Assigned To: Nandaja Varma
Anush Shetty
: ZStream
Depends On:
Blocks: 1255689 1299184
  Show dependency treegraph
 
Reported: 2015-09-28 06:44 EDT by Anush Shetty
Modified: 2016-07-03 21:12 EDT (History)
7 users (show)

See Also:
Fixed In Version: gdeploy-2.0-2
Doc Type: Bug Fix
Doc Text:
Rebalance operation tries to start the gluster volume before doing the actual rebalance. In most of the cases, volume is already in `Started' state. If the volume is already started and the volume start command fails, gdeploy thinks that volume has started and does not start the rebalance process.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-23 01:28:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anush Shetty 2015-09-28 06:44:56 EDT
Description of problem: If the volume is in "start" state, rebalance with gdeploy fails. 


Version-Release number of selected component (if applicable): gdeploy-1.0-12.el7rhgs.noarch


How reproducible: Always


Steps to Reproduce:
1. Create a conf file for running rebalance over a volume:

cat gconf:

[hosts]
rhshdp03.lab.eng.blr.redhat.com
rhshdp04.lab.eng.blr.redhat.com
rhshdp05.lab.eng.blr.redhat.com
rhshdp06.lab.eng.blr.redhat.com

[tune-profile]
none

[volume]
action=rebalance
volname=gluster_vol1
state=start
 
2. Run rebalance with gdeploy: gdeploy -c gconf


Actual results: Rebalance fails


Additional info:

# gdeploy -c gconf 
INFO: Volume management(action: rebalance) triggered

PLAY [master] ***************************************************************** 

TASK: [Starts a volume] ******************************************************* 
failed: [rhshdp04.lab.eng.blr.redhat.com] => {"failed": true}
msg: volume start: gluster_vol1: failed: Volume gluster_vol1 already started


FATAL: all hosts have already failed -- aborting

PLAY RECAP ******************************************************************** 
           to retry, use: --limit @/root/ansible_playbooks.retry

rhshdp04.lab.eng.blr.redhat.com : ok=0    changed=0    unreachable=0    failed=1
Comment 2 Nandaja Varma 2015-09-30 01:20:49 EDT
This bug exists in the present release and the cause of the issue is that rebalance operations tries to start the gluster volume before doing the actual rebalance. So if the volume is already started, rebalance would fail.

As a workaround, one could stop the volume and then try doing the rebalance.

In short, in the present release, rebalance in gdeploy is possible only for stopped volumes.
Comment 3 Anjana Suparna Sriram 2015-09-30 08:01:02 EDT
Edited the doc text, please review and sign off to be included in Known Issues chapter.
Comment 4 Nandaja Varma 2015-10-01 01:21:28 EDT
Looks good, Anjana.
Comment 5 Sachidananda Urs 2015-11-06 11:39:24 EST
Fixed in branch: https://github.com/gluster/gdeploy/tree/1.1
Comment 7 Anush Shetty 2016-04-06 05:41:47 EDT
Verified with gdeploy-2.0-2.el7rhgs.noarch
Comment 9 errata-xmlrpc 2016-06-23 01:28:41 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2016:1250

Note You need to log in before you can comment on or make changes to this bug.