Bug 1266883 - protocol/server: do not define the number of inodes in terms of memory units
protocol/server: do not define the number of inodes in terms of memory units
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: protocol (Show other bugs)
mainline
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Raghavendra Bhat
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-28 07:27 EDT by Raghavendra Bhat
Modified: 2016-06-16 09:39 EDT (History)
1 user (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-16 09:39:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raghavendra Bhat 2015-09-28 07:27:15 EDT
Description of problem:

The maximum number of inodes in the inode table is being defined as memory units instead of number. So is the description of the option.

.max   = (1 * GF_UNIT_MB),
.description = "Specifies the maximum megabytes of memory to be "
          "used in the inode cache.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Vijay Bellur 2015-10-15 12:35:28 EDT
COMMIT: http://review.gluster.org/12242 committed in master by Niels de Vos (ndevos@redhat.com) 
------
commit 0c02fefaf7d6b54f4d9cae2b1ae1f2b657857625
Author: Raghavendra Bhat <raghavendra@redhat.com>
Date:   Mon Sep 28 16:47:01 2015 +0530

    protocol/server: define the max number of inodes in lru list as a number
    
    * The max number of inodes in the lru list of the inode table was being defined
      in terms of memory units (GF_UNIT_MB) instead of number. And the description
      of the option was also referring to it in memory units instead of number.
    
    Change-Id: I48f07e7d2826406697eb2a13714ab22feae81d89
    BUG: 1266883
    Signed-off-by: Raghavendra Bhat <raghavendra@redhat.com>
    Reviewed-on: http://review.gluster.org/12242
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
Comment 2 Niels de Vos 2016-06-16 09:39:10 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.