Bug 1266904 - [rfe] equivalent of yumdownloader --urls
[rfe] equivalent of yumdownloader --urls
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-28 09:05 EDT by Ed Avis
Modified: 2015-10-13 09:51 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 09:30:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Avis 2015-09-28 09:05:17 EDT
The equivalent of yumdownloader is 'dnf download', but it doesn't support the --urls flag to just print out the URIs instead of downloading them.  I use this to check a local package list against the upstream packages, to see whether a newer or older upstream equivalent exists.  I don't want to actually download the upstream package, just look at its name.

Perhaps there is a better way to do that than getting the URI and parsing it for a version number, but generally this is a missing feature that's a regression from yum, and straightforward to provide (dnf download already knows what the URIs are, so it just needs to print them and exit).

Would you accept a patch to add a --urls flag?
Comment 1 Michal Luscon 2015-10-13 09:30:32 EDT
Hi Ed,

the situation with --url option is a bit more complicated than you probably expect. DNF actually does not know the URIs as the whole download process is handled by librepo library.

If you wan to still contribute a patch, I would advice you to contact the librepo developers first with an RFE describing your use case, and feel free to reopen this report after the implementation of necessary bits in librepo.
Comment 2 Ed Avis 2015-10-13 09:51:34 EDT
Thanks for your reply.  For my use case it is not necessary to see the URIs - I just filed the bug because I assumed they were easy to get.  But really what I would like to see is the version and release for the package of a particular name in the repo.  For example

% dnf repo-query bash
bash-4.3.42-1.fc22.x86_64

So a bit like 'rpm -q' but reporting what is available in the repo rather than what is installed.  Is there a dnf command which does that?

Note You need to log in before you can comment on or make changes to this bug.