Bug 1266925 - unable to deploy overcloud with commanderror Neutron tunnel types must be specified when Neutron network type is specified
unable to deploy overcloud with commanderror Neutron tunnel types must be spe...
Status: CLOSED DUPLICATE of bug 1266911
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 7.0 (Kilo)
Assigned To: chris alfonso
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-28 10:22 EDT by bigswitch
Modified: 2016-04-18 02:55 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-28 12:23:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bigswitch 2015-09-28 10:22:36 EDT
Description of problem:
attempt to deploy pre-GA code and getting below error:

openstack overcloud deploy -e /home/stack/templates/network-environment.yaml -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml -e /home/stack/templates/bigswitch-config.yaml --neutron-network-type vlan --neutron-network-vlan-ranges datacentre:2000:3000 --neutron-disable-tunneling --compute-scale 2 --control-scale 3 --ceph-storage-scale 0 --templates --control-flavor control --compute-flavor compute --ntp-server 0.rhel.pool.ntp.org --debug 2>&1 | tee haha-2042.log



DEBUG: keystoneclient.auth.identity.v2 Making authentication request to http://192.0.2.1:5000/v2.0/tokens
DEBUG: requests.packages.urllib3.connectionpool "POST /v2.0/tokens HTTP/1.1" 200 3551
DEBUG: rdomanager_oscplugin.v1.overcloud_deploy.DeployOvercloud take_action(Namespace(block_storage_flavor=None, block_storage_scale=None, ceph_storage_flavor=None, ceph_storage_scale=0, compute_flavor='compute', compute_scale=2, control_flavor='control', control_scale=3, environment_files=['/home/stack/templates/network-environment.yaml', '/usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml', '/home/stack/templates/bigswitch-config.yaml'], hypervisor_neutron_public_interface='nic1', libvirt_type='kvm', neutron_bridge_mappings=None, neutron_disable_tunneling=True, neutron_flat_networks=None, neutron_mechanism_drivers=None, neutron_network_type='vlan', neutron_network_vlan_ranges='datacentre:2000:3000', neutron_physical_bridge=None, neutron_public_interface=None, neutron_tunnel_id_ranges='1:1000', neutron_tunnel_types=None, neutron_vni_ranges='1:1000', no_proxy='', ntp_server='0.rhel.pool.ntp.org', output_dir=None, plan=None, reg_activation_key='', reg_force=False, reg_method='satellite', reg_org='', reg_sat_url='', rhel_reg=False, stack='overcloud', swift_storage_flavor=None, swift_storage_scale=None, templates='/usr/share/openstack-tripleo-heat-templates/', timeout=240, tripleo_root='/etc/tripleo', validation_errors_fatal=False, validation_warnings_fatal=False))
ERROR: openstack Neutron tunnel types must be specified when Neutron network type is specified
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/cliff/app.py", line 295, in run_subcommand
    result = cmd.run(parsed_args)
  File "/usr/lib/python2.7/site-packages/cliff/command.py", line 53, in run
    self.take_action(parsed_args)
  File "/usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_deploy.py", line 1161, in take_action
    self._validate_args(parsed_args)
  File "/usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_deploy.py", line 750, in _validate_args
    raise oscexc.CommandError("Neutron tunnel types must be specified "
CommandError: Neutron tunnel types must be specified when Neutron network type is specified
DEBUG: openstackclient.shell clean_up DeployOvercloud
DEBUG: openstackclient.shell got an error: Neutron tunnel types must be specified when Neutron network type is specified
ERROR: openstackclient.shell Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/openstackclient/shell.py", line 176, in run
    return super(OpenStackShell, self).run(argv)
  File "/usr/lib/python2.7/site-packages/cliff/app.py", line 230, in run
    result = self.run_subcommand(remainder)
  File "/usr/lib/python2.7/site-packages/cliff/app.py", line 295, in run_subcommand
    result = cmd.run(parsed_args)
  File "/usr/lib/python2.7/site-packages/cliff/command.py", line 53, in run
    self.take_action(parsed_args)
  File "/usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_deploy.py", line 1161, in take_action
    self._validate_args(parsed_args)
  File "/usr/lib/python2.7/site-packages/rdomanager_oscplugin/v1/overcloud_deploy.py", line 750, in _validate_args
    raise oscexc.CommandError("Neutron tunnel types must be specified "
CommandError: Neutron tunnel types must be specified when Neutron network type is specified

[stack@c5220-01 ~]$

Version-Release number of selected component (if applicable):
7.0 pre-GA

How reproducible:
100%

Steps to Reproduce:
1. Deploy pre-GA code on undercloud
2. Attempt to deploy overcloud
3.

Actual results:


Expected results:


Additional info:
Comment 2 bigswitch 2015-09-28 12:23:34 EDT

*** This bug has been marked as a duplicate of bug 1266911 ***

Note You need to log in before you can comment on or make changes to this bug.