Bug 1266944 - ns-slapd crash during ipa-replica-manage del
Summary: ns-slapd crash during ipa-replica-manage del
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Noriko Hosoi
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-28 15:38 UTC by Scott Poore
Modified: 2020-09-13 21:33 UTC (History)
5 users (show)

Fixed In Version: 389-ds-base-1.3.4.0-19.el7
Doc Type: Bug Fix
Doc Text:
Since it is a regression, no doc is needed.
Clone Of:
Environment:
Last Closed: 2015-11-19 11:44:18 UTC
Target Upstream Version:


Attachments (Terms of Use)
abrt dir for crash (11.20 MB, application/x-gzip)
2015-09-28 15:43 UTC, Scott Poore
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github 389ds 389-ds-base issues 1629 0 None None None 2020-09-13 21:33:14 UTC
Red Hat Product Errata RHBA-2015:2351 0 normal SHIPPED_LIVE 389-ds-base bug fix and enhancement update 2015-11-19 10:28:44 UTC

Description Scott Poore 2015-09-28 15:38:21 UTC
Description of problem:

During some ipa-replica-manage del tests, I see ns-slapd crash.

Core was generated by `/usr/sbin/ns-slapd -D /etc/dirsrv/slapd-TESTRELM-TEST -i /var/run/dirsrv/slapd-'.
Program terminated with signal 11, Segmentation fault.
#0  slapi_sdn_copy (from=0x0, to=to@entry=0x7f526809b390) at ldap/servers/slapd/dn.c:2474
2474            if (from->udn)



Version-Release number of selected component (if applicable):
389-ds-base-1.3.4.0-18.el7.x86_64
ipa-server-4.2.0-12.el7.x86_64


How reproducible:
unknown

Steps to Reproduce:
Exact steps unknown. 

I saw the crash in a 5 node IPA server environment setup in a simple chain:

R1-M-R2-R3-R4

When I saw the crash it was on R3 doing ipa-replica-manage del R4.

Actual results:
ns-slapd crashes.

Expected results:
no crash

Additional info:
I will upload abrt crash dir.

Comment 1 Scott Poore 2015-09-28 15:43:33 UTC
Created attachment 1077964 [details]
abrt dir for crash

Comment 7 Noriko Hosoi 2015-09-28 19:10:20 UTC
Upstream ticket:
https://fedorahosted.org/389/ticket/48298

Comment 10 Scott Poore 2015-09-28 21:09:51 UTC
I just saw this again in the same place and it's confirmed to be the same crash.  I'm marking this TestBlocker since it is repeatable and is blocking tests from completing properly.

Comment 18 Scott Poore 2015-10-07 17:20:46 UTC
Verified.

Version ::

389-ds-base-1.3.4.0-19.el7.x86_64

Results ::

I've run a full battery of ipa-replica-manage tests where this was originally seen.  I have not seen this issue again.

And here you can see a good del call:

:: [  BEGIN   ] :: Running 'ipa-replica-manage -p Secret123 del nocp9.testrelm.test -f 2>&1 | tee /tmp/output.irm_useradd 2>&1'
ipa: INFO: Setting agreement cn=meTodell-pe1950-03.testrelm.test,cn=replica,cn=dc\=testrelm\,dc\=test,cn=mapping tree,cn=config schedule to 2358-2359 0 to force synch
ipa: INFO: Deleting schedule 2358-2359 0 from agreement cn=meTodell-pe1950-03.testrelm.test,cn=replica,cn=dc\=testrelm\,dc\=test,cn=mapping tree,cn=config
ipa: INFO: Replication Update in progress: FALSE: status: 0 Replica acquired successfully: Incremental update succeeded: start: 0: end: 0
Deleting replication agreements between nocp9.testrelm.test and dell-pe1950-03.testrelm.test
Deleted replication agreement from 'dell-pe1950-03.testrelm.test' to 'nocp9.testrelm.test'
Background task created to clean replication data. This may take a while.
This may be safely interrupted with Ctrl+C
:: [   PASS   ] :: Command 'ipa-replica-manage -p Secret123 del nocp9.testrelm.test -f 2>&1 | tee /tmp/output.irm_useradd 2>&1' (Expected 0, got 0)

And here it shows that the replication agreement was indeed removed:

:: [  BEGIN   ] :: Running 'ipa-replica-manage -p Secret123 list > /tmp/output.irm_useradd 2>&1'
:: [   PASS   ] :: Command 'ipa-replica-manage -p Secret123 list > /tmp/output.irm_useradd 2>&1' (Expected 0, got 0)
:: [  BEGIN   ] :: Running 'cat /tmp/output.irm_useradd'
dell-pe1950-02.testrelm.test: master
idm-qe-01.testrelm.test: master
dell-pe1950-03.testrelm.test: master
idm-qe-02.testrelm.test: master
:: [   PASS   ] :: Command 'cat /tmp/output.irm_useradd' (Expected 0, got 0)
:: [   PASS   ] :: File '/tmp/output.irm_useradd' should not contain 'nocp9.testrelm.test' 


No crashes seen.  Before crashes were causing tests to pause due to other debugging traps for failures.  No pauses or hangs and with no crashes, this one is verified.

Comment 19 errata-xmlrpc 2015-11-19 11:44:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2351.html


Note You need to log in before you can comment on or make changes to this bug.