Bug 1266949 - dnf distro-sync --allowerasing --releasever=23 --exclude='kernel*' removes all versions of the kernel
dnf distro-sync --allowerasing --releasever=23 --exclude='kernel*' removes al...
Status: CLOSED DUPLICATE of bug 1260989
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
22
i686 Linux
unspecified Severity medium
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-28 11:54 EDT by Bruno Wolff III
Modified: 2015-10-13 09:24 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-13 09:24:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Raw typescript file from problematic upgrade (14.66 MB, text/plain)
2015-09-28 12:32 EDT, Bruno Wolff III
no flags Details

  None (edit)
Description Bruno Wolff III 2015-09-28 11:54:58 EDT
User-Agent:       
Build Identifier: 

When I tried dnf distro-sync --allowerasing --releasever=23 I got an error because dnf was going to remove the running kernel. So I tried dnf distro-sync --allowerasing --releasever=23 --exclude='kernel*' figuring that would skip any kernel updates. Instead they were all removed. If you notice before you reboot it is fixable. But if you don't, lots of fun can be involved. Especially with very old hardware.

Reproducible: Always
Comment 1 Bruno Wolff III 2015-09-28 12:21:40 EDT
Just using dnf distro-sync --allowerasing --exclude='kernel*' doesn't trigger the bug. I mostly have rawhide nodebug kernels installed.
Comment 2 Bruno Wolff III 2015-09-28 12:25:03 EDT
dnf distro-sync --allowerasing --exclude='kernel*' --disablerepo=fedora-rawhide-kernel-nodebug didn't trigger the issue either.
Comment 3 Bruno Wolff III 2015-09-28 12:32 EDT
Created attachment 1077993 [details]
Raw typescript file from problematic upgrade

The typescript file is raw and has terminal escape sequences in it. (I started out using vi to fix some repo files pointing to a local mirror of f23.) But it might provide some insight into why the kernels all got removed.
Comment 4 Honza Silhan 2015-10-13 09:24:06 EDT

*** This bug has been marked as a duplicate of bug 1260989 ***

Note You need to log in before you can comment on or make changes to this bug.