Bug 1266952 - Can no longer exclude packages from a group in kickstart
Can no longer exclude packages from a group in kickstart
Status: CLOSED DUPLICATE of bug 1199868
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F23FinalBlocker
  Show dependency treegraph
 
Reported: 2015-09-28 12:07 EDT by Orion Poplawski
Modified: 2015-09-28 13:39 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-28 13:05:33 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda.log (8.23 KB, text/plain)
2015-09-28 12:08 EDT, Orion Poplawski
no flags Details
dnf.log (430.39 KB, text/plain)
2015-09-28 12:09 EDT, Orion Poplawski
no flags Details
packaging.log (15.16 KB, text/plain)
2015-09-28 12:09 EDT, Orion Poplawski
no flags Details

  None (edit)
Description Orion Poplawski 2015-09-28 12:07:38 EDT
Description of problem:

I have:

@kde-desktop
-apper

However with F23 Beta, apper gets installed:

dnf.log:
Sep 22 15:18:25 DEBUG Adding packages from group 'kde-desktop': {'kget', 'kde-partitionmanager', 'plasma-desktop-doc', 'kwrite', 'NetworkManager-config-connectivity-fedora', 'plasma-desktop', 'ksnapshot', 'plasma-nm-vpnc', 'kdnssd', 'plasma-nm-openvpn', 'plasma-nm-pptp', 'kdegraphics-strigi-analyzer', 'akregator', 'akonadi', 'polkit-kde', 'gnome-keyring-pam', 'xsettings-kde', 'ksysguard', 'knode', 'kamera', 'sddm', 'plasma-breeze', 'xorg-x11-drv-libinput', 'gwenview', 'kcm_systemd', 'kcalc', 'kdegames-minimal', 'kruler', 'colord-kde', 'sni-qt', 'plasma-pk-updates', 'kwin', 'kwebkitpart', 'plasma-nm-l2tp', 'sddm-breeze', 'kipi-plugins', 'muon-discover', 'phonon-qt5-backend-gstreamer', 'kcolorchooser', 'kscreen', 'pam-kwallet', 'kinfocenter', 'plasma-pa', 'kde-baseapps', 'kdegraphics-thumbnailers', 'adwaita-gtk2-theme', 'ksshaskpass', 'kwalletmanager', 'plasma-nm-openswan', 'appmenu-qt', 'dolphin', 'akonadi-mysql', 'kaddressbook', 'kf5-baloo-file', 'khelpcenter', 'cups-pk-helper', 'kmail', 'abrt-desktop', 'firewall-config', 'kdeplasma-addons', 'phonon-backend-gstreamer', 'kuser', 'kgpg', 'kcharselect', 'sddm-kcm', 'breeze-icon-theme', 'kde-print-manager', 'kde-settings-pulseaudio', 'apper', 'kdelibs', 'initial-setup-gui', 'kdeaccessibility', 'korganizer', 'kwalletmanager5', 'bluedevil', 'plasma-workspace', 'plasma-nm', 'plasma-nm-openconnect', 'kde-style-breeze', 'kontact', 'kde-runtime', 'konsole5', 'kcm-gtk', 'cagibi'}
Sep 22 17:39:01 INFO Installed: apper-0.9.1-12.fc23.x86_64

Version-Release number of selected component (if applicable):
23.19.4-1
Comment 1 Orion Poplawski 2015-09-28 12:08 EDT
Created attachment 1077989 [details]
anaconda.log
Comment 2 Orion Poplawski 2015-09-28 12:09 EDT
Created attachment 1077990 [details]
dnf.log
Comment 3 Orion Poplawski 2015-09-28 12:09 EDT
Created attachment 1077991 [details]
packaging.log
Comment 4 David Shea 2015-09-28 13:05:33 EDT
#!/usr/bin/python3
import tempfile
import os
import dnf

tempdir = tempfile.mkdtemp(prefix='test-dnf.')
cachedir = os.path.join(tempdir, 'dnf.cache')
logdir = os.path.join(tempdir, 'dnf.logs')
installroot = os.path.join(tempdir, 'installroot')
os.mkdir(cachedir)
os.mkdir(logdir)
os.mkdir(installroot)

base = dnf.Base()
base.conf.cachedir = cachedir
base.conf.logdir = logdir
base.conf.installroot = installroot
base.conf.releasever = 'rawhide'

repo = dnf.repo.Repo('dnf-test-1', cachedir)
repo.baseurl = ['http://dl.fedoraproject.org/pub/fedora/linux/development/rawhide/x86_64/os/']
repo.skip_if_unavailable = False
repo.enable()
base.repos.add(repo)
repo.load()

base.fill_sack(load_system_repo=False)
base.read_comps()

# The important part:
base.group_install('kde-desktop', {'default', 'mandatory'}, exclude=['apper'])
base.resolve()
for pkg in base.transaction.install_set:
    print(pkg.pkgtup)

dshea@dshea-ws:~$ python3 dnftest.py | grep "'apper'"
('apper', 'x86_64', '0', '0.9.1', '12.fc23')

*** This bug has been marked as a duplicate of bug 1199868 ***

Note You need to log in before you can comment on or make changes to this bug.