Bug 1266990 - python-xhtml2pdf deps not satisfied
python-xhtml2pdf deps not satisfied
Status: CLOSED DUPLICATE of bug 1245113
Product: Fedora
Classification: Fedora
Component: python-xhtml2pdf (Show other bugs)
22
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Major Hayden
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-28 14:29 EDT by lejeczek
Modified: 2015-09-28 14:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-28 14:42:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lejeczek 2015-09-28 14:29:40 EDT
Description of problem:

$ xhtml2pdf
****************************************************
IMPORT ERROR!
Reportlab Version 2.1+ is needed!
****************************************************

The following Python packages are required for PISA:
- Reportlab Toolkit >= 2.2 <http://www.reportlab.org/>
- HTML5lib >= 0.11.1 <http://code.google.com/p/html5lib/>

Optional packages:
- pyPDF <http://pybrary.net/pyPdf/>
- PIL <http://www.pythonware.com/products/pil/>

No handlers could be found for logger "xhtml2pdf"
Traceback (most recent call last):
  File "/usr/bin/xhtml2pdf", line 9, in <module>
    load_entry_point('xhtml2pdf==0.0.5', 'console_scripts', 'xhtml2pdf')()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 558, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2682, in load_entry_point
    return ep.load()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2355, in load
    return self.resolve()
  File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 2361, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/usr/lib/python2.7/site-packages/xhtml2pdf/__init__.py", line 41, in <module>
    from xhtml2pdf.util import REPORTLAB22
  File "/usr/lib/python2.7/site-packages/xhtml2pdf/util.py", line 39, in <module>
    raise ImportError("Reportlab Version 2.1+ is needed!")
ImportError: Reportlab Version 2.1+ is needed!


Version-Release number of selected component (if applicable):

python3-reportlab-3.1.8-4.fc22.x86_64
python-reportlab-3.1.8-4.fc22.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Major Hayden 2015-09-28 14:42:18 EDT
Hey there,

This is a duplicate of 1245113.  I have a COPR of python-xhtml2pdf 0.6 here:

https://copr.fedoraproject.org/coprs/mhayden/python-xhtml2pdf/

That should fix it temporarily.  The final fix (as mentioned in bug 1245113) is to get a new version of python-PyPDF2 into Fedora.  I'm working on that package review now.

*** This bug has been marked as a duplicate of bug 1245113 ***

Note You need to log in before you can comment on or make changes to this bug.