Bug 1266991 - Allow usage of OpenLDAP libraries that don't use NSS for crypto
Allow usage of OpenLDAP libraries that don't use NSS for crypto
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Noriko Hosoi
Viktor Ashirov
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-28 14:36 EDT by Noriko Hosoi
Modified: 2017-08-01 17:10 EDT (History)
4 users (show)

See Also:
Fixed In Version: 389-ds-base-1.3.6.1-3.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2017-08-01 17:10:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noriko Hosoi 2015-09-28 14:36:49 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/389/ticket/48034
Comment 1 Noriko Hosoi 2016-11-09 18:34:26 EST
Design Doc: http://www.port389.org/docs/389ds/design/allow-usage-of-openldap-lib-w-openssl.html

Test case: ticket47536_test.py
Comment 3 Sankar Ramalingam 2017-05-15 22:26:06 EDT
Marking it as Verified based on the upstream test results.

[0 root@qeos-43 ds]# py.test -s -v dirsrvtests/tests/tickets/ticket47536_test.py 
===================================================== test session starts =====================================================
platform linux2 -- Python 2.7.5, pytest-3.0.7, py-1.4.33, pluggy-0.4.0 -- /usr/bin/python
cachedir: .cache


INFO:dirsrvtests.tests.tickets.ticket47536_test:
######################### Adding 5 entries to master2 ######################

INFO:dirsrvtests.tests.tickets.ticket47536_test:##### Searching for entries on master1...
INFO:dirsrvtests.tests.tickets.ticket47536_test:##### Searching for entries on master2...
INFO:dirsrvtests.tests.tickets.ticket47536_test:##### db2ldif.pl -- ['/usr/sbin/db2ldif.pl', '-n', 'userRoot', '-Z', 'master_1', '-D', 'cn=Directory Manager', '-w', 'password']
INFO:dirsrvtests.tests.tickets.ticket47536_test:      OUT:
INFO:dirsrvtests.tests.tickets.ticket47536_test:      Exporting to ldif file: /var/lib/dirsrv/slapd-master_1/ldif/master_1-userRoot-2017_5_15_22_22_38.ldif

INFO:dirsrvtests.tests.tickets.ticket47536_test:      Successfully added task entry "cn=export_2017_5_15_22_22_38, cn=export, cn=tasks, cn=config"

INFO:dirsrvtests.tests.tickets.ticket47536_test:      ERR:
INFO:dirsrvtests.tests.tickets.ticket47536_test:Ticket 47536 - PASSED
PASSEDInstance slapd-master_1 removed.
Instance slapd-master_2 removed.


================== 1 passed in 55.52 seconds ===================

DS build: 1.3.6.1
389-ds-base: 1.3.6.1-13.el7
nss: 3.28.4-8.el7
nspr: 4.13.1-1.0.el7_3
openldap: 2.4.44-4.el7
svrcore: 4.1.3-2.el7
Comment 4 errata-xmlrpc 2017-08-01 17:10:21 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2086

Note You need to log in before you can comment on or make changes to this bug.