Bug 1267029 - [abrt] gnome-dvb-daemon: InitialTuningDataPage.py:379:_fill_providers:OSError: [Errno 2] No such file or directory: '/usr/share/dvb/dvb-t'
[abrt] gnome-dvb-daemon: InitialTuningDataPage.py:379:_fill_providers:OSError...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-dvb-daemon (Show other bugs)
23
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jens Lody
Fedora Extras Quality Assurance
https://retrace.fedoraproject.org/faf...
abrt_hash:b8ebb7980f32a1ced05c8eeb7f6...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-28 17:00 EDT by zimon
Modified: 2016-09-30 11:53 EDT (History)
1 user (show)

See Also:
Fixed In Version: gnome-dvb-daemon-0.2.91-0.2.20160917git2d32148.fc25 gnome-dvb-daemon-0.2.91-0.2.20160917git2d32148.fc23 gnome-dvb-daemon-0.2.91-0.2.20160917git2d32148.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-09-22 03:31:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (624 bytes, text/plain)
2015-09-28 17:00 EDT, zimon
no flags Details
File: environ (3.96 KB, text/plain)
2015-09-28 17:00 EDT, zimon
no flags Details

  None (edit)
Description zimon 2015-09-28 17:00:42 EDT
Description of problem:
Started gnome-dvb-setup
It wanted to set up.
Chose another of the two dvb-t frontends.
In country and antena selection, chose a country, Next.
aBrtd noticed a crash of gnome-dvb-daemon

Version-Release number of selected component:
gnome-dvb-daemon-0.2.10-4.fc21

Additional info:
reporter:       libreport-2.6.2
cmdline:        python /usr/bin/gnome-dvb-setup
executable:     /usr/bin/gnome-dvb-setup
kernel:         4.2.1-300.fc23.x86_64
runlevel:       N 5
type:           Python
uid:            500

Truncated backtrace:
InitialTuningDataPage.py:379:_fill_providers:OSError: [Errno 2] No such file or directory: '/usr/share/dvb/dvb-t'

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/gnomedvb/ui/wizard/pages/InitialTuningDataPage.py", line 379, in _fill_providers
    for f in os.listdir(os.path.join(d, self.__data_dir)):
OSError: [Errno 2] No such file or directory: '/usr/share/dvb/dvb-t'

Local variables in innermost frame:
selected_country: 'fi'
self: <InitialTuningDataPage object at 0x7fab831a3050 (gnomedvb+ui+wizard+pages+InitialTuningDataPage+InitialTuningDataPage at 0x55c838209e20)>
d: '/usr/share/dvb'
Comment 1 zimon 2015-09-28 17:00:46 EDT
Created attachment 1078068 [details]
File: backtrace
Comment 2 zimon 2015-09-28 17:00:47 EDT
Created attachment 1078069 [details]
File: environ
Comment 3 zimon 2015-10-01 03:30:06 EDT
The problem is, I think, there is no rpm package providing /usr/share/dvb in Fedora 23. There is dtv-scan-tables package which does provide /usr/share/dvbv5 and ../dvb-t/ inside that.

If I make a soft link, I do not get that error from gnome-dvb-setup.

$ rpm -qf /usr/share/dvb
file /usr/share/dvb is not owned by any package

$ rpm -qf /usr/share/dvbv5
dtv-scan-tables-1-3.20140905git4aad313.fc23.noarch

$ rpm -qf /usr/share/dvbv5/dvb-t
dtv-scan-tables-1-3.20140905git4aad313.fc23.noarch

$ sudo ln -s dvbv5 /usr/share/dvb
Comment 4 Fedora Admin XMLRPC Client 2016-09-15 11:37:15 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Fedora Admin XMLRPC Client 2016-09-16 04:16:48 EDT
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 6 Fedora Update System 2016-09-18 12:41:50 EDT
gnome-dvb-daemon-0.2.91-0.2.20160917git2d32148.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-2af0a89013
Comment 7 Fedora Update System 2016-09-18 12:42:04 EDT
gnome-dvb-daemon-0.2.91-0.2.20160917git2d32148.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-7c6ffd31e2
Comment 8 Fedora Update System 2016-09-18 12:42:15 EDT
gnome-dvb-daemon-0.2.91-0.2.20160917git2d32148.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-bea4f12b9c
Comment 9 Fedora Update System 2016-09-19 00:19:39 EDT
gnome-dvb-daemon-0.2.91-0.2.20160917git2d32148.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-2af0a89013
Comment 10 Fedora Update System 2016-09-19 00:22:13 EDT
gnome-dvb-daemon-0.2.91-0.2.20160917git2d32148.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-bea4f12b9c
Comment 11 Fedora Update System 2016-09-19 01:22:13 EDT
gnome-dvb-daemon-0.2.91-0.2.20160917git2d32148.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-7c6ffd31e2
Comment 12 Fedora Update System 2016-09-22 03:31:01 EDT
gnome-dvb-daemon-0.2.91-0.2.20160917git2d32148.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2016-09-29 18:51:56 EDT
gnome-dvb-daemon-0.2.91-0.2.20160917git2d32148.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2016-09-30 11:53:23 EDT
gnome-dvb-daemon-0.2.91-0.2.20160917git2d32148.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.