Bug 1267043 - Timeout tunnel should be set for the nova_novncproxy haproxy config
Timeout tunnel should be set for the nova_novncproxy haproxy config
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-puppet-modules (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
high Severity medium
: ---
: 7.0 (Kilo)
Assigned To: Javier Peña
Ido Ovadia
: Triaged, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-28 19:18 EDT by Marius Cornea
Modified: 2018-01-17 12:22 EST (History)
14 users (show)

See Also:
Fixed In Version: openstack-puppet-modules-2015.1.8-53.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-01-17 12:22:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nova-novncproxy.log error (3.11 KB, text/plain)
2015-09-28 19:18 EDT, Marius Cornea
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 232986 None None None Never

  None (edit)
Description Marius Cornea 2015-09-28 19:18:52 EDT
Created attachment 1078083 [details]
nova-novncproxy.log error

Description of problem:
The console session in the browser gets disconnected with Server disconnected (code: 1006) message. As suggested in BZ#1257324 'timeout tunnel 1h' should be set for the nova_novncproxy section in haproxy.cfg. Additional info can be found here:
http://blog.haproxy.com/2012/11/07/websockets-load-balancing-with-haproxy/

Version-Release number of selected component (if applicable):
openstack-puppet-modules-2015.1.8-17.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. Open console session in browser
2. Keep the window open

Actual results:
Eventually the session gets disconnected with Server disconnected (code: 1006) message.

Expected results:
The session stays connected.

Additional info:
Attaching the error message in /var/log/nova/nova-novncproxy.log.
Comment 2 Javier Peña 2015-10-09 07:29:52 EDT
Proposed https://review.openstack.org/232986 with the fix.
Comment 4 Mike McCune 2016-03-28 18:48:26 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 7 Ido Ovadia 2016-09-15 11:24:31 EDT
Failed QA
=========

Reproduce on openstack-puppet-modules-2015.1.8-53.el7ost.noarch

Steps to Reproduce:
=================== 

   1. Install director and build an overcloud environment with
      HA-Controllers(haproxy) configuration.
   
   2. Update Overcloud 

   3. Access horizon from your browser with virtual IP.

   4. Create an instance

   5. Open console session in browser

   6. Keep the window open
   
Actual results:
===============
Eventually the session gets disconnected with Server disconnected (code: 1006) message.

Expected results:
=================
The session stays connected.
Comment 11 Artom Lifshitz 2018-01-17 12:22:39 EST
I'm going to overrule the failedQA and close this, because while my confidence in the upstream fix *is* diminished by the failedQA, we need to be realistic: at this point we're not going to deploy OSP7 in instance HA with director to re-QA this.

Note You need to log in before you can comment on or make changes to this bug.