Bug 1267044 - Ethernet network slow / TCP retransmits / Large frames [module: e1000e]
Ethernet network slow / TCP retransmits / Large frames [module: e1000e]
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-28 19:23 EDT by Andreas Gruenbacher
Modified: 2015-09-29 17:00 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-29 17:00:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Traffic to the problematic node A (deleted)
2015-09-28 19:23 EDT, Andreas Gruenbacher
no flags Details
Traffic from the problematic node A (128.74 KB, application/octet-stream)
2015-09-28 19:24 EDT, Andreas Gruenbacher
no flags Details

  None (edit)
Description Andreas Gruenbacher 2015-09-28 19:23:55 EDT
Description of problem:
I'm having severe network performance problems when copying files to an Intel NUC with an "Intel Corporation Ethernet Connection (3) I218-V (rev 03)" Ethernet controller. When copying files to this node ("node a"), the remote side ("node b") decides to send large frames and the node rejects them, leading to inane amounts of retransmits. When copying files from node A to node B, node A also sends large frames, but node B accepts them.

I'm seeing the problem with different B nodes which are connected by switches (I have tried two different switches). When node B is connected through a router, the frame size apparently stays small and the problem doesn't trigger.

The MTU side on both sides is set to the standard 1500 bytes.

Version-Release number of selected component (if applicable):
Fedora 23 Beta 1

How reproducible:
Always

Actual results:
Huge amounts of retransmits, abysmal network performance.

Expected results:
No retransmits, normal network performance.
Comment 1 Andreas Gruenbacher 2015-09-28 19:24 EDT
Created attachment 1078085 [details]
Traffic from the problematic node A
Comment 2 Andreas Gruenbacher 2015-09-29 17:00:39 EDT
Weird, I cannot reproduce the bug anymore, and I'm not sure what made it go away. I'm closing this bug for now.

Note You need to log in before you can comment on or make changes to this bug.