Bug 1267131 - Multipath is not correctly identifying iscsi devices, and misconfiguring them.
Multipath is not correctly identifying iscsi devices, and misconfiguring them.
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: device-mapper-multipath (Show other bugs)
7.1
Unspecified Unspecified
high Severity unspecified
: rc
: ---
Assigned To: Ben Marzinski
Lin Li
: ZStream
Depends On: 1254292
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-29 01:12 EDT by Jan Kurik
Modified: 2015-11-03 11:14 EST (History)
15 users (show)

See Also:
Fixed In Version: device-mapper-multipath-0.4.9-77.el7_1.2
Doc Type: Bug Fix
Doc Text:
Cause: To determine if a device was an iscsi device, multipath was checking the "tgtname" sysfs file. The file name has changed to be "targetname". This meant that multipath was not correctly identifying iscsi devices as such, and would not use the iscsi specific configuration functions. Consequence: Multipath would not correctly set fast_io_fail_tmo for iscsi device. Fix: Multipath now checks for both "tgtname" and "targetname" Result: Multipath correctly identifies iscsi devices as such, and configures them correctly.
Story Points: ---
Clone Of: 1254292
Environment:
Last Closed: 2015-11-03 11:14:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-09-29 01:12:20 EDT
This bug has been copied from bug #1254292 and has been proposed
to be backported to 7.1 z-stream (EUS).
Comment 5 Lin Li 2015-10-08 05:02:45 EDT
verified on RHEL-7.1;  device-mapper-multipath-0.4.9-77.el7_1.2
steps:
1.#yum -y install device-mapper-multipath-0.4.9-77.el7_1.2.x86_64.rpm device-mapper-multipath-libs-0.4.9-77.el7_1.2.x86_64.rpm kpartx-0.4.9-77.el7_1.2.x86_64.rpm
2.# rpm -qa | grep multipath
device-mapper-multipath-0.4.9-77.el7_1.2.x86_64
device-mapper-multipath-libs-0.4.9-77.el7_1.2.x86_64
3.#mpathconf --enable
4.#service multipathd restart
5.#configure multipath 
6.# mpathconf 
  multipath is enabled
  find_multipaths is disabled
  user_friendly_names is disabled
  dm_multipath module is loaded
  multipathd is running
7.# cat /etc/multipath.conf 
defaults {
    polling_interval            5
    no_path_retry               fail
    user_friendly_names         no
    flush_on_last_del           yes
    fast_io_fail_tmo            5
    dev_loss_tmo                30
    max_fds                     4096
}
devices {
    device {
        all_devs                yes
        no_path_retry           fail
    }
}
8.#cat /sys/class/iscsi_session/session1/recovery_tmo 
  5
Comment 6 Lin Li 2015-10-08 05:04:09 EDT
verified on hp-dl385g7-05.rhts.eng.nay.redhat.com.
change to vevified.
Comment 8 errata-xmlrpc 2015-11-03 11:14:17 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1966.html

Note You need to log in before you can comment on or make changes to this bug.