Bug 1267161 - TypeError: 'str' does not support the buffer interface
Summary: TypeError: 'str' does not support the buffer interface
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mock
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Suchý
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-29 08:04 UTC by Vít Ondruch
Modified: 2016-01-03 23:26 UTC (History)
7 users (show)

Fixed In Version: mock-1.2.14-1.fc23 mock-1.2.14-1.el6 mock-1.2.14-1.fc22 mock-1.2.14-1.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-27 18:21:08 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1171737 0 unspecified CLOSED mock --orphanskills does not work with systemd-nspawn 2021-02-22 00:41:40 UTC

Internal Links: 1171737

Description Vít Ondruch 2015-09-29 08:04:54 UTC
Description of problem:
$ mock -r ruby ruby-2.3.0-0.5.r51856.fc24.src.rpm 
INFO: mock.py version 1.2.13 starting (python version = 3.4.3)...
Start: init plugins
INFO: selinux disabled
Finish: init plugins
Start: run
INFO: Start(ruby-2.3.0-0.5.r51856.fc24.src.rpm)  Config(ruby)
Start: clean chroot
ERROR: Exception(ruby-2.3.0-0.5.r51856.fc24.src.rpm) Config(ruby) 0 minutes 0 seconds
INFO: Results and/or logs in: /var/lib/mock/ruby/result
ERROR: 'str' does not support the buffer interface
Traceback (most recent call last):
  File "/usr/sbin/mock", line 649, in main
    run_command(options, args, config_opts, commands, buildroot, state)
  File "/usr/lib/python3.4/site-packages/mockbuild/trace_decorator.py", line 84, in trace
    result = func(*args, **kw)
  File "/usr/sbin/mock", line 729, in run_command
    do_rebuild(config_opts, commands, buildroot, args)
  File "/usr/lib/python3.4/site-packages/mockbuild/trace_decorator.py", line 84, in trace
    result = func(*args, **kw)
  File "/usr/sbin/mock", line 495, in do_rebuild
    post=post_build, clean=clean)
  File "/usr/lib/python3.4/site-packages/mockbuild/trace_decorator.py", line 84, in trace
    result = func(*args, **kw)
  File "/usr/sbin/mock", line 438, in rebuild_generic
    commands.clean()
  File "/usr/lib/python3.4/site-packages/mockbuild/trace_decorator.py", line 84, in trace
    result = func(*args, **kw)
  File "/usr/lib/python3.4/site-packages/mockbuild/backend.py", line 72, in clean
    self.buildroot.delete()
  File "/usr/lib/python3.4/site-packages/mockbuild/trace_decorator.py", line 84, in trace
    result = func(*args, **kw)
  File "/usr/lib/python3.4/site-packages/mockbuild/buildroot.py", line 556, in delete
    util.orphansKill(p)
  File "/usr/lib/python3.4/site-packages/mockbuild/trace_decorator.py", line 84, in trace
    result = func(*args, **kw)
  File "/usr/lib/python3.4/site-packages/mockbuild/util.py", line 186, in orphansKill
    for name in vm_list.split("\n"):
TypeError: 'str' does not support the buffer interface

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/usr/sbin/mock", line 833, in <module>
    main()
  File "/usr/lib/python3.4/site-packages/mockbuild/trace_decorator.py", line 84, in trace
    result = func(*args, **kw)
  File "/usr/sbin/mock", line 651, in main
    buildroot.finalize()
  File "/usr/lib/python3.4/site-packages/mockbuild/trace_decorator.py", line 84, in trace
    result = func(*args, **kw)
  File "/usr/lib/python3.4/site-packages/mockbuild/buildroot.py", line 540, in finalize
    util.orphansKill(self.make_chroot_path())
  File "/usr/lib/python3.4/site-packages/mockbuild/trace_decorator.py", line 84, in trace
    result = func(*args, **kw)
  File "/usr/lib/python3.4/site-packages/mockbuild/util.py", line 186, in orphansKill
    for name in vm_list.split("\n"):
TypeError: 'str' does not support the buffer interface



Version-Release number of selected component (if applicable):
$ rpm -q mock
mock-1.2.13-2.fc24.noarch


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
This seems to be Python3 incompatibility introduced by bug 1171737. I can use --old-chroot as a workaround.

Comment 1 Miroslav Suchý 2015-09-29 08:33:42 UTC
I can confirm. This does not happen on F22, it hapen only on F23+ where mock use python3

Comment 2 Miroslav Suchý 2015-10-05 07:53:01 UTC
Fixed in commit:
* 789274c (origin/devel) decode shell output when running under Python3 [RHBZ#1267161]

Comment 3 Dominik 'Rathann' Mierzejewski 2015-10-12 13:04:50 UTC
This happens on F22 with mock-1.2.13-2.fc22. Downgrading to mock-1.2.8-1.fc22 makes it work again. How did that end up in stable updates?

Comment 4 Dominik 'Rathann' Mierzejewski 2015-11-17 10:03:46 UTC
Still reproducible on F23:
mock-1.2.13-2.fc23.noarch

I don't see any new updates for mock.

Comment 5 Fedora Update System 2015-11-24 23:31:52 UTC
mock-1.2.14-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-a295f19cae

Comment 6 Fedora Update System 2015-11-24 23:31:55 UTC
mock-1.2.14-1.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-6d1cc55330

Comment 7 Fedora Update System 2015-11-24 23:32:24 UTC
mock-1.2.14-1.fc21 has been submitted as an update to Fedora 21. https://bodhi.fedoraproject.org/updates/FEDORA-2015-b4d491366d

Comment 8 Fedora Update System 2015-11-24 23:32:26 UTC
mock-1.2.14-1.el6 has been submitted as an update to Fedora EPEL 6. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-fd9c932e3a

Comment 9 Fedora Update System 2015-11-24 23:32:57 UTC
mock-1.2.14-1.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-3ef940024e

Comment 10 Fedora Update System 2015-11-26 00:51:15 UTC
mock-1.2.14-1.el6 has been pushed to the Fedora EPEL 6 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update mock'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-fd9c932e3a

Comment 11 Fedora Update System 2015-11-26 00:53:18 UTC
mock-1.2.14-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'yum --enablerepo=epel-testing update mock'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2015-a295f19cae

Comment 12 Fedora Update System 2015-11-26 01:22:02 UTC
mock-1.2.14-1.fc21 has been pushed to the Fedora 21 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update mock'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-b4d491366d

Comment 13 Fedora Update System 2015-11-26 02:25:36 UTC
mock-1.2.14-1.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update mock'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-3ef940024e

Comment 14 Fedora Update System 2015-11-26 02:54:34 UTC
mock-1.2.14-1.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update mock'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-6d1cc55330

Comment 15 Fedora Update System 2015-11-27 18:20:38 UTC
mock-1.2.14-1.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Comment 16 Fedora Update System 2016-01-03 20:26:26 UTC
mock-1.2.14-1.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2016-01-03 21:20:14 UTC
mock-1.2.14-1.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Comment 18 Fedora Update System 2016-01-03 23:26:11 UTC
mock-1.2.14-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.