Bug 1267205 - X server crashes when power cord plugged in or un-plugged
X server crashes when power cord plugged in or un-plugged
Status: CLOSED DUPLICATE of bug 1293093
Product: Fedora
Classification: Fedora
Component: gnome-shell (Show other bugs)
22
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Owen Taylor
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-29 06:40 EDT by Alexander Demchenko
Modified: 2015-12-19 23:58 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-19 23:58:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/home/al/.local/share/xorg/Xorg.0.log (25.20 KB, text/plain)
2015-09-29 06:40 EDT, Alexander Demchenko
no flags Details
journalctl -b -0 (1.56 MB, text/x-vhdl)
2015-09-29 06:48 EDT, Alexander Demchenko
no flags Details

  None (edit)
Description Alexander Demchenko 2015-09-29 06:40:06 EDT
Created attachment 1078283 [details]
/home/al/.local/share/xorg/Xorg.0.log

Description of problem:

I have notebook Lenovo T410s with Fedora 22 installed. Every time when i plug in or un-plug power cord x-server crashes and lost my session.

Version-Release number of selected component (if applicable):
xorg-x11-server-Xorg.x86_64            1.17.2-2.fc22

How reproducible:


Steps to Reproduce:
1. Start my gnome session
2. Unplug power cord
Comment 1 Alexander Demchenko 2015-09-29 06:48:00 EDT
сен 28 22:58:35 collider-mts.localdomain /usr/libexec/gdm-x-session[1287]: (EE) Server terminated with error (1). Closing log file.
Comment 2 Alexander Demchenko 2015-09-29 06:48 EDT
Created attachment 1078285 [details]
journalctl -b -0
Comment 3 Hans de Goede 2015-09-29 07:48:02 EDT
This seems to be the culprit:

сен 29 20:12:15 collider-mts.localdomain audit[17590]: <audit-1701> auid=1000 uid=0 gid=0 ses=6 subj=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 pid=17590 comm="gnome-shell" exe="/usr/bin/gnome-shell" sig=5
сен 29 20:12:15 collider-mts.localdomain kernel: traps: gnome-shell[17590] trap int3 ip:7f19c0bd0d3b sp:7ffd0dc43d20 error:0
сен 29 20:12:15 collider-mts.localdomain abrt-hook-ccpp[17592]: Not saving repeating crash in '/usr/bin/gnome-shell'

Changing component to gnome-shell. It is probably useful if you file a bug with a backtrace through abrt.
Comment 4 Alexander Demchenko 2015-09-29 10:55:10 EDT
Hmmm.. Abrt i had crash at ~ 00:43. But ABRT didn't generate report.

сен 30 00:43:32 collider-mts.localdomain /usr/libexec/gdm-x-session[1311]: (EE) Server terminated with error (1). Closing log file.

ls -l /var/spool/abrt | grep 09-30
drwxr-x---. 3 root abrt     4096 сен 30 00:51 ccpp-2015-09-30-00:23:58-1318
Comment 5 Alexander Demchenko 2015-12-19 23:58:07 EST
Created new bug hrough abrt 1293093.

*** This bug has been marked as a duplicate of bug 1293093 ***

Note You need to log in before you can comment on or make changes to this bug.