Bug 1267206 - ipa-server-install uninstall should warn if no installation found
Summary: ipa-server-install uninstall should warn if no installation found
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Pavel Picka
QA Contact: Namita Soman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-29 10:41 UTC by Abhijeet Kasurde
Modified: 2016-11-04 05:46 UTC (History)
5 users (show)

Fixed In Version: ipa-4.3.1-0.201605191449GITf8edf37.el7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-11-04 05:46:57 UTC


Attachments (Terms of Use)
evidence (2.51 KB, text/plain)
2016-09-16 07:12 UTC, Pavel Picka
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:2404 normal SHIPPED_LIVE ipa bug fix and enhancement update 2016-11-03 13:56:18 UTC

Description Abhijeet Kasurde 2015-09-29 10:41:05 UTC
Description of problem:
`ipa-server-install --uninstall -U` should warn user if no installation of ipa-server is found on machine. This is behavior should be same as 'ipa-server-install --install' where command checks for previous installation of ipa-server.

Version-Release number of selected component (if applicable):
ipa-server-4.2.0-12.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install IPA server 
2. Uninstall IPA server
3. again start un-installation of IPA server 

Actual results:
ipa-server-install command always perform un-installation steps irrespective of installed instance of IPA server

Expected results:
2nd and subsequent time of un-installation of ipa-server should check install instance of IPA server.

Additional info:

Comment 3 Petr Vobornik 2015-10-05 15:56:25 UTC
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/5341

Comment 4 Martin Bašti 🖰 2015-10-22 12:12:15 UTC
Only warning message has been added. Uninstaller should be idempotent.

Fixed upstream
master:
https://fedorahosted.org/freeipa/changeset/a0b8415236addf0ff32b9e05b2491d626d483171
ipa-4-2:
https://fedorahosted.org/freeipa/changeset/85dc0c2e3a396ff7d8d429a414b717cc01231b26

Comment 5 Mike McCune 2016-03-28 23:03:07 UTC
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Comment 7 Pavel Picka 2016-09-16 07:12:52 UTC
Created attachment 1201548 [details]
evidence

Verified

4.4.0-11

Comment 9 errata-xmlrpc 2016-11-04 05:46:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-2404.html


Note You need to log in before you can comment on or make changes to this bug.