Bug 1267213 - Getting 'Unexpected error encountered' exception page while accessing Pods and Container Services page.
Getting 'Unexpected error encountered' exception page while accessing Pods an...
Status: CLOSED WORKSFORME
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS (Show other bugs)
5.5.0
Unspecified Unspecified
high Severity medium
: GA
: 5.5.0
Assigned To: Alissa
Dave Johnson
:
: 1267214 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-29 07:10 EDT by Nikhil Gupta
Modified: 2015-11-11 15:32 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-30 10:46:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nikhil Gupta 2015-09-29 07:10:18 EDT
Description of problem:

- Go to "CFME webui -> Containers -> Pods", it is giving below error:
~~~
ERROR: column container_groups.project does not exist LINE 1: ...stems"."id" = "container_groups"."ems_id" WHERE ((container_... ^ [container_group/show_list] 
~~~

- Go to "CFME webui -> Containers -> Container Services", it is giving below error:
~~~
 ERROR: column container_services.project does not exist LINE 1: ...ems"."id" = "container_services"."ems_id" WHERE ((container_... ^ [container_service/show_list] 
~~~

Version-Release number of selected component (if applicable):

5.5.0.1-alpha1.20150915151429_2230bd4


How reproducible:
Always

Actual results:
Getting exception.

Expected results:
It should load respective page.

Additional info:
While these pages as below, it is showing respective pages:

Go to "CFME webui -> Containers -> Providers -> Relationships -> Pods/Container Services

Test environment: https://10.65.234.116/ (User:admin Pass:smartvm)
Comment 2 Alissa 2015-09-30 10:45:19 EDT
*** Bug 1267214 has been marked as a duplicate of this bug. ***
Comment 3 Alissa 2015-09-30 10:46:49 EDT
I can't reproduce it on the latest master.
Also, from the error above it seems that the schema migration was not completed/not properly ran, so the code on that environment does not match db schema. 
Please update that environment - both code and db (db:migrate) and recheck.

Note You need to log in before you can comment on or make changes to this bug.