Bug 1267229 - parameter based on matcher doesn't show value during new host creation
parameter based on matcher doesn't show value during new host creation
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Provisioning (Show other bugs)
6.1.2
Unspecified Unspecified
unspecified Severity medium (vote)
: GA
: --
Assigned To: orabin
Katello QA List
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-29 07:59 EDT by Fred van Zwieten
Modified: 2016-07-27 07:16 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:16:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
smart class parameter with matcher on domain (55.94 KB, image/png)
2016-07-01 09:51 EDT, Ondřej Pražák
no flags Details
parameter resolution when creating new host (22.97 KB, image/png)
2016-07-01 09:52 EDT, Ondřej Pražák
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14790 None None None 2016-04-24 10:03 EDT

  None (edit)
Description Fred van Zwieten 2015-09-29 07:59:58 EDT
Description of problem:
When creating a new host, class parameters that match on a smart class parameter match value do not show the match before the new host is created. It does show after the host is created. This means the user is not able to view the actual value chosen before the host is created and thus cannot decide if this is the correct value or that it should override it for this host.

Version-Release number of selected component (if applicable):


How reproducible:
Create smart class parameter with override enabled and a matcher on i.e. domain
Open dialog new host to create new host making sure the matcher should match
Go to parameters and see what the chosen value is

Steps to Reproduce:
1.
2.
3.

Actual results:
chosen value is empty

Expected results:
is should show the chosen value


Additional info:
Apperantly, it resolves these matchers during host creation, but imho that is too late.
Comment 2 orabin 2016-04-24 09:55:56 EDT
Created redmine issue http://projects.theforeman.org/issues/14790 from this bug
Comment 3 Bryan Kearney 2016-04-27 10:10:40 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14790 has been closed
Comment 4 Ondřej Pražák 2016-07-01 09:51 EDT
Created attachment 1174935 [details]
smart class parameter with matcher on domain
Comment 5 Ondřej Pražák 2016-07-01 09:52 EDT
Created attachment 1174936 [details]
parameter resolution when creating new host
Comment 6 Ondřej Pražák 2016-07-01 09:55:03 EDT
Verified on RHEL7, snap 18.1
Comment 7 Bryan Kearney 2016-07-27 07:16:07 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.