This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 126723 - issues with the gimp desktop entry
issues with the gimp desktop entry
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-06-25 07:41 EDT by Ville Skyttä
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-23 11:46:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ville Skyttä 2004-06-25 07:41:46 EDT
gimp-2.0.2-1.fc2.2's gimp.desktop has some issues:

- Ugly legacy encodings, and lacks the Encoding=Legacy-Mixed key.
- Lacks GenericName (should be "Image Editor" if Name is
  "GIMP Image Editor"; see GNOME HIG).
- Non-GNOME HIG compliant Comment fields
- Terminal=0 is deprecated, should be Terminal=false
- Missing trailing semicolon in Categories
- No MimeType definitions, adding those would allow "Open with GIMP 
  Image Editor" for images at least in Konqueror, perhaps GNOME too.

To me it looks like it would be a better strategy to use
desktop-file-install to install and use the upstream .desktop file,
and apply the GenericName, Name and MimeType changes there instead of
shipping an external, somewhat outdated one.
Comment 1 Nils Philippsen 2004-06-26 04:19:21 EDT
Seth, you made the change to "GIMP Image Editor" in the old desktop
file -- I see some small problems:

If I use the shipped desktop file (which I'm inclined to do) and
change the Name, all the translations are gone. I could patch the
generated files, but then the translations would be wrong. I could
just not change the shipped desktop file, but then it would be listed
as "The GIMP" in the menu. If I change the desktop file, we would
either have to get the change accepted upstream or update myriads of
translations and maintain this patch indefinitely.

What's your opinion on how we should handle this?
Comment 2 Nils Philippsen 2004-08-02 10:17:25 EDT
Current gimp packages (in FC2-updates-testing and Rawhide/devel) use
the files as shipped in the tarball, could you check whether the
issues still persist? Thanks.
Comment 3 Ville Skyttä 2004-08-05 17:56:10 EDT
Skimming the desktop entry in gimp-2.0.3-2: it looks quite a bit
better, and the remaining issues are upstream ones, and not that big
deal.  Namely:
- GenericName missing (should be "<Name> Image Editor" or somesuch, 
  properly i18n'd, see GNOME HIG development version)
- Still no MimeType entries (see initial comment in this bug)

As far as I'm concerned, this can be closed.  Feel free to report the
remaining bits upstream if you feel like it :)
Comment 4 Nils Philippsen 2004-11-23 11:46:09 EST
gimp-2.2-pre has GenericName and MimeType

Note You need to log in before you can comment on or make changes to this bug.