Bug 1267231 - Missing x-forwarded headers in ose-ha-proxy
Missing x-forwarded headers in ose-ha-proxy
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Routing (Show other bugs)
3.0.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Ram Ranganathan
zhaozhanqi
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-29 08:04 EDT by Miheer Salunke
Modified: 2015-11-23 09:45 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 09:45:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Origin (Github) 4549 None None None Never

  None (edit)
Description Miheer Salunke 2015-09-29 08:04:06 EDT
Description of problem:
The official ose-ha-proxy image for the router in OSE3 misses the x-forwarded header (both protocol, host and port), so the example jenkins app doesn't work fine.

Version-Release number of selected component (if applicable):
3.0

How reproducible:
Always

Steps to Reproduce:
1.When accessing jenkins via https, it redirects sometimes to http because the missing x-forwarded header.
2.
3.

Actual results:
missing x-forwarded header

Expected results:
x-forwarded header shall be present in order to avoid issues.
Eg- When accessing jenkins via https, it redirects sometimes to http because the missing x-forwarded header.

Additional info:
Comment 2 Ram Ranganathan 2015-10-15 14:16:57 EDT
This is fixed  via https://github.com/openshift/origin/pull/4705 - 
should be in the next OSE release.
Comment 3 zhaozhanqi 2015-10-30 02:09:38 EDT
verified this bug on 
haproxy images id: f3efd662337a
oc v3.0.2.903-114-g2849767
kubernetes v1.2.0-alpha.1-1107-g4c8e6f4
jenkins app works well

Note You need to log in before you can comment on or make changes to this bug.