Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1267244 - Query fails with "Index contains unexpected zero page"
Summary: Query fails with "Index contains unexpected zero page"
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Bugzilla
Classification: Community
Component: Database
Version: 4.4
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
Assignee: PnT DevOps Devs
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-29 12:40 UTC by Petr Šplíchal
Modified: 2016-06-01 01:47 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-14 05:01:57 UTC


Attachments (Terms of Use)

Description Petr Šplíchal 2015-09-29 12:40:51 UTC
Description of problem:

When querying for bugs patched during the last week using the
python-bugzilla module I ran into the following error:

Fault -32000: 'DBD::Pg::db selectall_arrayref failed: ERROR:
index "bugs_activity_bug_id_idx" contains unexpected zero page at
block 47180\nHINT:  Please REINDEX it.

Version-Release number of selected component (if applicable):
4.4.9039-7

Steps to Reproduce:
[ DEBUG ] Search query:
[ DEBUG ] {u'field0-0-0': u'keywords',
 u'field0-1-0': u'keywords',
 u'field0-2-0': u'keywords',
 u'field0-3-0': u'keywords',
 u'query_format': u'advanced',
 u'type0-0-0': u'changedby',
 u'type0-1-0': u'changedto',
 u'type0-2-0': u'changedafter',
 u'type0-3-0': u'changedbefore',
 u'value0-0-0': u'psplicha@redhat.com',
 u'value0-1-0': u'Patch',
 u'value0-2-0': '2015-09-21',
 u'value0-3-0': '2015-09-28'}

Comment 1 Jason McDonald 2015-09-30 06:48:59 UTC
The database had two corrupted table indexes, which have been dropped and recreated, so you should no longer see the error.  Root cause investigation is ongoing.

Comment 2 Muhammad Tahir 2015-10-14 05:01:57 UTC
Reindexing has been performed.


Note You need to log in before you can comment on or make changes to this bug.