Bug 1267281 - KScreen crashes when changing resolution for vncviewer
Summary: KScreen crashes when changing resolution for vncviewer
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libkscreen
Version: 7.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jan Grulich
QA Contact: Desktop QE
URL: https://quickgit.kde.org/?p=libkscree...
Whiteboard:
Depends On:
Blocks: 1313485 1479818
TreeView+ depends on / blocked
 
Reported: 2015-09-29 14:15 UTC by Jan Grulich
Modified: 2018-10-26 07:58 UTC (History)
2 users (show)

Fixed In Version: libkscreen-1.0.1-8.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 11:31:43 UTC


Attachments (Terms of Use)
Backtrace of the crash (6.22 KB, text/plain)
2015-09-29 14:15 UTC, Jan Grulich
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0717 None None None 2018-04-10 11:33:40 UTC
KDE Software Compilation 323107 None None None Never
KDE Software Compilation 324625 None None None Never

Description Jan Grulich 2015-09-29 14:15:26 UTC
Created attachment 1078382 [details]
Backtrace of the crash

Description of problem:
KScreen crashes when trying to change resolution for vncviewer. It's reproducible almost every time, only in few cases it succeeds to change the resolution. Using "xrandr -s XXXXxYYYY" works pretty well. The issue is actually in libkscreen library and is already fixed in upstream.

Version-Release number of selected component (if applicable):
libkscreen-1.0.1-6.el7

Comment 3 Jan Grulich 2016-02-15 10:26:42 UTC
Easily reproducible, granting dev_ack+.

Comment 6 Jan Grulich 2017-09-11 08:13:14 UTC
Fixed in libkscreen-1.0.1-8.el7.

Comment 12 errata-xmlrpc 2018-04-10 11:31:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0717


Note You need to log in before you can comment on or make changes to this bug.