Bug 1267287 - The Available Subscriptions frame does not resize the subcomponents correctly
The Available Subscriptions frame does not resize the subcomponents correctly
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: candlepin-bugs
Sean Toner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-29 10:32 EDT by Sean Toner
Modified: 2015-11-19 06:51 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 06:51:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
table is not sized correctly to outer frame (765.48 KB, image/png)
2015-09-29 10:32 EDT, Sean Toner
no flags Details
table can resize correctly (111.76 KB, image/png)
2015-10-01 11:30 EDT, Sean Toner
no flags Details

  None (edit)
Description Sean Toner 2015-09-29 10:32:42 EDT
Created attachment 1078400 [details]
table is not sized correctly to outer frame

Description of problem:
=======================

On the Available Subscriptions tab of the subscription-manager-gui, when it comes up the embedded table is not sized properly with the main GUI.  If the user tries to resize the GUI, it does not alter the table at all.

See screenshot


Version-Release number of selected component (if applicable):
=============================================================

subscription-manager-gui-1.15.9-12.el7.x86_64


How reproducible:
=================

Always


Steps to Reproduce:
1. Register a system
2. Go to the Available Subscriptions tab
3. Resize the main GUI window

Actual results:
===============

See screenshot


Expected results:
=================

The table should be sized accordingly to the main GUI window both on intial startup and if the user resizes the window.


Additional info:
Comment 2 Adrian Likins 2015-09-29 14:09:14 EDT
pr at https://github.com/candlepin/subscription-manager/pull/1307
Comment 3 Chris Snyder 2015-09-29 15:00:45 EDT
In master as of commit: e7503348784bb53b31c5e46fa9c233786d79f5c7
Comment 4 Chris Rog 2015-09-30 10:01:34 EDT
commit e7503348784bb53b31c5e46fa9c233786d79f5c7
Author: Adrian Likins <alikins@redhat.com>
Date:   Tue Sep 29 14:05:45 2015 -0400

    1267287: Fix allsubs tab ui regression
    
    Revert to the previous version. The reverted
    version did not resize properly and the
    GtkAdjustment use isn't a problem in this
    dialog.
Comment 6 Sean Toner 2015-10-01 11:29:27 EDT
Fixed now (see screenshot)
Comment 7 Sean Toner 2015-10-01 11:30 EDT
Created attachment 1079190 [details]
table can resize correctly
Comment 8 Sean Toner 2015-10-01 11:30:38 EDT
[root@dhcp129-70 ~]# rpm -qa | grep subscription
subscription-manager-1.15.9-13.el7.x86_64
subscription-manager-gui-1.15.9-13.el7.x86_64
subscription-manager-initial-setup-addon-1.15.9-13.el7.x86_64
Comment 9 errata-xmlrpc 2015-11-19 06:51:11 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2122.html

Note You need to log in before you can comment on or make changes to this bug.