Bug 1267290 - Copying XML Schema Model problem
Copying XML Schema Model problem
Status: CLOSED NOTABUG
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Tooling (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Barry LaFond
Matus Makovy
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-29 10:45 EDT by skaleta
Modified: 2015-12-07 08:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 08:21:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
project with schemas (3.02 KB, application/zip)
2015-09-29 10:45 EDT, skaleta
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIIDDES-2670 Optional Open Copying XML Schema Model problem 2015-12-08 07:03 EST

  None (edit)
Description skaleta 2015-09-29 10:45:23 EDT
Created attachment 1078402 [details]
project with schemas

When creating new XML Schema (XSD) Model by copying from existing model (see steps to reproduce), action fails with error (and new empty schema) for some schemas (e.g. schemas in attachement).

Error message: 
Error attempting to load a Model Editor Page plugin
ID = org.teiid.designer.xsd.ui.editor.XsdSimpleDatatypesEditorPage@611ddac3

Exception Stack Trace:
... 
Caused by: org.xml.sax.SAXParseException ... ... lineNumber: 1; columnNumber: 1; Premature end of file.

I assume it might be something with line endings of Windows text files, because it happened only for files originally created in Windows for me (However some schemas created in Windows works properly).

Steps to reproduce:
1. Import attached project
2. Right-click on project and select New > Teiid Metadata Model
3. Set new name and select "XML Schema (XSD)" Model Class, "Datatype" Model Type, Module Builder: "Copy from existing model of the same model class" and click Next >
4. browse for existing: <ImportedProjectName>/notWorking.xsd (or notWorking2.xsd) and click OK and Finish
Comment 1 Barry LaFond 2015-12-07 08:21:26 EST
Using only JIRA now.  Marking as closed

Note You need to log in before you can comment on or make changes to this bug.