Bug 1267299 - The return code for 'redhat-access-insights' should be 1 when the upload is not successful after unregistering the client from Satellite 6 UI.
The return code for 'redhat-access-insights' should be 1 when the upload is n...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: redhat-access-insights (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: jcrafts
Anisha Narang
:
Depends On:
Blocks: 1274384
  Show dependency treegraph
 
Reported: 2015-09-29 11:01 EDT by Anisha Narang
Modified: 2016-05-10 20:43 EDT (History)
3 users (show)

See Also:
Fixed In Version: redhat-access-insights-1.0.7-3.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-10 20:43:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Anisha Narang 2015-09-29 11:01:46 EDT
Description of problem:
The return code for 'redhat-access-insights' should be 1 when the upload is not successful after unregistering the client from Satellite 6 UI.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Register a VM to RHAI service using redhat-access-inisghts --register
2. From the Satellite 6 UI dashboard, unregister the client.
3. On the client machine, try to upload again:

>>> [10.8.30.181] redhat-access-insights
Attemping to download collection rules from https://qe-sat6-rhel71.usersys.redhat.com:443/redhat_access/r/insights/v1/static/uploader.json
Successfully downloaded collection rules
Attemping to download collection rules GPG signature from https://qe-sat6-rhel71.usersys.redhat.com:443/redhat_access/r/insights/v1/static/uploader.json.asc
Successfully downloaded GPG signature
Verifying GPG signature of Insights configuration
Starting to collect Insights data
Uploading Insights data, this may take a few minutes
Upload attempt 1 of 1 failed! Status Code: 412
All attempts to upload have failed!
Please see /var/log/redhat-access-insights/redhat-access-insights.log for additional information

The return code for the above command is 0, whereas it should be 1.

Actual results:
The return code is 0(success)

Expected results:
The return code should be 1(failure).

Additional info:
Comment 4 errata-xmlrpc 2016-05-10 20:43:19 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0928.html

Note You need to log in before you can comment on or make changes to this bug.