Bug 1267302 - nl_BE.utf8 settings gone in Mate Desktop
nl_BE.utf8 settings gone in Mate Desktop
Status: NEW
Product: Fedora EPEL
Classification: Fedora
Component: lightdm (Show other bugs)
epel7
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-29 11:03 EDT by Johan Vermeulen
Modified: 2015-09-30 10:07 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Johan Vermeulen 2015-09-29 11:03:28 EDT
Description of problem: Desktop no longer displayed in Dutch


Version-Release number of selected component (if applicable): mate-desktop.x86_64                 1.10.2-1.el7


How reproducible: apply recent Epel-Mate updates


Steps to Reproduce:
1.
2.
3.

Actual results: Desktop now displays Applications - Locations - System 
and displays time and date in form and language unknown to me.


Expected results: Display desktop settings in Dutch : Toepassingen - Locaties - Systeem


Additional info:
these were Mate-components that were recently updated on one laptop:

Sep 16 12:43:28 Bijgewerkt: mate-settings-daemon.x86_64 1.10.2-1.el7
Sep 21 16:39:52 Bijgewerkt: mate-utils-common.noarch 1.10.3-1.el7
Sep 21 16:39:54 Bijgewerkt: mate-system-log.x86_64 1.10.3-1.el7
Sep 21 16:39:56 Bijgewerkt: mate-dictionary.x86_64 1.10.3-1.el7
Sep 21 16:39:57 Bijgewerkt: mate-disk-usage-analyzer.x86_64 1.10.3-1.el7
Sep 21 16:39:58 Bijgewerkt: mate-screenshot.x86_64 1.10.3-1.el7
Sep 21 16:39:59 Bijgewerkt: mate-search-tool.x86_64 1.10.3-1.el7
Sep 21 16:40:01 Bijgewerkt: mate-power-manager.x86_64 1.10.2-1.el7
Sep 28 13:31:29 Bijgewerkt: lightdm-gobject.x86_64 1.10.4-6.el7
Sep 28 13:31:31 Bijgewerkt: lightdm-gtk-common.noarch 1.8.5-19.el7
Sep 28 13:31:32 Bijgewerkt: lightdm.x86_64 1.10.4-6.el7
Sep 28 13:31:33 Bijgewerkt: lightdm-gtk.x86_64 1.8.5-19.el7

Until now 5 users with Centos7-Mate laptops reported this issue.
Comment 1 Wolfgang Ulbrich 2015-09-29 12:28:12 EDT
Can you please attach a full yum history logs of those days?
Use
yum history
yum history list <id>

Can you set nl language via lightdm, note, normal you need login/logout 2 times for some reasons for changing languages with lightdm.

Can you try downgrade lightdm and in a second step mate-settings-daemon to target the culprit package?

What is the output of 'locale'?
Comment 2 Wolfgang Ulbrich 2015-09-29 12:43:29 EDT
opps,
i meant yum history info <id>
Comment 3 Johan Vermeulen 2015-09-30 05:05:45 EDT
Hello,

before I start posting output of yum history or downgrading
packages;
I have 10 machines in storage that were last updated sept 23 and
are not affected yet.
Is it useful to update one package at the time of anything like that?

Greetings, Johan

Ouput yum update :

[root@localhost ~]# yum update
Geladen plugins: fastestmirror
adobe-linux-x86_64                                                                                                                                        |  951 B  00:00:00     
base                                                                                                                                                      | 3.6 kB  00:00:00     
epel/x86_64/metalink                                                                                                                                      |  25 kB  00:00:00     
epel                                                                                                                                                      | 4.3 kB  00:00:00     
extras                                                                                                                                                    | 3.4 kB  00:00:00     
nux-dextop                                                                                                                                                | 2.9 kB  00:00:00     
updates                                                                                                                                                   | 3.4 kB  00:00:00     
(1/8): base/7/x86_64/group_gz                                                                                                                             | 154 kB  00:00:00     
(2/8): epel/x86_64/group_gz                                                                                                                               | 169 kB  00:00:00     
(3/8): epel/x86_64/updateinfo                                                                                                                             | 361 kB  00:00:00     
(4/8): extras/7/x86_64/primary_db                                                                                                                         |  87 kB  00:00:00     
(5/8): base/7/x86_64/primary_db                                                                                                                           | 5.1 MB  00:00:01     
(6/8): nux-dextop/x86_64/primary_db                                                                                                                       | 1.4 MB  00:00:01     
(7/8): epel/x86_64/primary_db                                                                                                                             | 3.5 MB  00:00:01     
(8/8): updates/7/x86_64/primary_db                                                                                                                        | 4.0 MB  00:00:04     
adobe-linux-x86_64/primary                                                                                                                                | 1.2 kB  00:00:00     
Determining fastest mirrors
 * base: ftp.belnet.be
 * epel: mirror0.babylon.network
 * extras: centos.cu.be
 * nux-dextop: mirror.li.nux.ro
 * updates: centos.mirrors.ovh.net
adobe-linux-x86_64                                                                                                                                                           2/2
Oplossen van afhankelijkheden
--> Transactiecontrole uitvoeren
---> Pakket grub2.x86_64 1:2.02-0.17.el7.centos.4.0.1 wordt bijgewerkt
---> Pakket grub2.x86_64 1:2.02-0.17.0.1.el7.centos.4 wordt een update
---> Pakket grub2-tools.x86_64 1:2.02-0.17.el7.centos.4.0.1 wordt bijgewerkt
---> Pakket grub2-tools.x86_64 1:2.02-0.17.0.1.el7.centos.4 wordt een update
---> Pakket lightdm.x86_64 0:1.6.3-4.el7 wordt bijgewerkt
---> Pakket lightdm.x86_64 0:1.10.4-6.el7 wordt een update
---> Pakket lightdm-gobject.x86_64 0:1.6.3-4.el7 wordt bijgewerkt
---> Pakket lightdm-gobject.x86_64 0:1.10.4-6.el7 wordt een update
---> Pakket lightdm-gtk.x86_64 0:1.8.5-16.el7 wordt bijgewerkt
---> Pakket lightdm-gtk.x86_64 0:1.8.5-19.el7 wordt een update
---> Pakket lightdm-gtk-common.noarch 0:1.8.5-16.el7 wordt bijgewerkt
---> Pakket lightdm-gtk-common.noarch 0:1.8.5-19.el7 wordt een update
---> Pakket openldap.x86_64 0:2.4.39-6.el7 wordt bijgewerkt
---> Pakket openldap.x86_64 0:2.4.39-7.el7.centos wordt een update
---> Pakket qt-settings.noarch 0:19-23.5.el7 wordt bijgewerkt
---> Pakket qt-settings.noarch 0:19-23.5.el7.centos wordt een update
--> Klaar met oplossen afhankelijkheden

Afhankelijkheden opgelost

=================================================================================================================================================================================
 Package                                      Arch                             Versie                                                    Repository                        Grootte
=================================================================================================================================================================================
Bijwerken:
 grub2                                        x86_64                           1:2.02-0.17.0.1.el7.centos.4                              updates                           1.5 M
 grub2-tools                                  x86_64                           1:2.02-0.17.0.1.el7.centos.4                              updates                           3.3 M
 lightdm                                      x86_64                           1.10.4-6.el7                                              epel                              186 k
 lightdm-gobject                              x86_64                           1.10.4-6.el7                                              epel                               56 k
 lightdm-gtk                                  x86_64                           1.8.5-19.el7                                              epel                               58 k
 lightdm-gtk-common                           noarch                           1.8.5-19.el7                                              epel                               57 k
 openldap                                     x86_64                           2.4.39-7.el7.centos                                       updates                           344 k
 qt-settings                                  noarch                           19-23.5.el7.centos                                        updates                            17 k

Transactie Samenvatting
=================================================================================================================================================================================
Upgrade  8 Pakketten

Totale download grootte: 5.4 M
Is this ok [y/d/N]:
Comment 4 Wolfgang Ulbrich 2015-09-30 05:41:36 EDT
I did update a Centos7 VM, which wasn't updated sinces a month, and i can't reproduce that nl_BE.utf8 was switched to another language.
So i don't think that lightdm or mate-settings-daemon can cause such a issue.
The question is more can you reset the affected boxes, via 'system-config-language' (system wide, needs restart) or lightdm's language switcher (needs 2 logins)?
Btw, do you see nl_BE.utf8 with both tools?
Maybe the language is removed by another package.
I would update non updated boxes in single steps, for better reproducing.
Comment 5 Johan Vermeulen 2015-09-30 08:02:47 EDT
Hello Wolfgang,

I updated one package at the time and rebooted after each update.
After this update the language change appears:

Bijwerken:
 lightdm-gobject                                 x86_64                                 1.10.4-6.el7                                   epel                                  56 k
Updaten vanwege afhankelijkheden:
 lightdm                                         x86_64                                 1.10.4-6.el7                                   epel                                 186 k

Transactie Samenvatting
==================================================================================================================================================================================
Upgrade  1 Pakket (+1 Afhankelijk pakket)

Totale download grootte: 242 k
Is this ok [y/d/N]: y
Downloading packages:Delta
RPMs disabled because /usr/bin/applydeltarpm not installed.
(1/2): lightdm-gobject-1.10.4-6.el7.x86_64.rpm                                                                                                             |  56 kB  00:00:00    
(2/2): lightdm-1.10.4-6.el7.x86_64.rpm                                                                                                                     | 186 kB  00:00:00    
----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------
Totaal                                                                                                                                            420 kB/s | 242 kB  00:00:00    
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Bijwerken               : lightdm-gobject-1.10.4-6.el7.x86_64                                                                                                               1/4
  Bijwerken               : lightdm-1.10.4-6.el7.x86_64                                                                                                                       2/4
  Opruimen                : lightdm-1.6.3-4.el7.x86_64                                                                                                                        3/4
  Opruimen                : lightdm-gobject-1.6.3-4.el7.x86_64                                                                                                                4/4
  Verifiëren              : lightdm-1.10.4-6.el7.x86_64                                                                                                                       1/4
  Verifiëren              : lightdm-gobject-1.10.4-6.el7.x86_64                                                                                                               2/4
  Verifiëren              : lightdm-gobject-1.6.3-4.el7.x86_64                                                                                                                3/4
  Verifiëren              : lightdm-1.6.3-4.el7.x86_64                                                                                                                        4/4

Bijgewerkt:
  lightdm-gobject.x86_64 0:1.10.4-6.el7                                                                                                                                          

Afhankelijkheid bijgewerkt:
  lightdm.x86_64 0:1.10.4-6.el7                                                                                                                                                  

Compleet!



After this a ran system-config-language and selected Dutch ( Belgium )
A message appears saying
Dutch language support is not installed. Do you want to install it?
Then this message comes up:

Waarschuwing: Groep dutch-support heeft geen pakketten om te installeren.
Resolving Dependencies

Dependencies Resolved

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Downloading Packages:
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction

Complete!

Note : this was also the case before the update
       the same thing comes up when selecting Dutch ( Nederlands )

After that I selected Nederlands-België on the top right corner of the
login screen.
Indeed, after two logins, this solves the issue.

Greetings, Johan
Comment 6 Johan Vermeulen 2015-09-30 08:13:35 EDT
So in a way  this update corrected an issue.
Because when installing Centos7 and selecting Dutch - Belgian ( alternative ),
in the end the locale displayed in Lightdm is aa_DJ.utf8
and the text is in Dutch.
Now one has to select the right locale in lightdm to see settings in Dutch.

Greetings, Johan
Comment 7 Wolfgang Ulbrich 2015-09-30 10:02:21 EDT
Johan,
good that that you can select dutch language and restore your boxes.
But that shouldn't happend with a update of lightdm.
So war i know is lightdm updated to latest LTS branch for rhel7.
Let's see what lightdm main maintainer thinks about.
Comment 8 Rex Dieter 2015-09-30 10:07:25 EDT
I think prior releases of lightdm didn't support this, so may have had to language set (so defaulted to something else... english?)

That's just a guess on my part.

Note You need to log in before you can comment on or make changes to this bug.