Bug 1267312 - muon-discover not showing any packages
muon-discover not showing any packages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: appstream (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F23FinalBlocker
  Show dependency treegraph
 
Reported: 2015-09-29 11:30 EDT by Dan Mossor [danofsatx]
Modified: 2015-10-07 12:35 EDT (History)
6 users (show)

See Also:
Fixed In Version: appstream-0.8.4-3.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-07 12:35:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dan Mossor [danofsatx] 2015-09-29 11:30:31 EDT
muon-discover-5.4.1-1.fc23.x86_64 does not show any packages in F23. Even on the "Installed" tab that shows available updates in the title, no packages are shown.
Comment 1 Dan Mossor [danofsatx] 2015-09-29 11:33:56 EDT
Proposing as a blocker per Final Release Criteria "Default Application Criteria":

All applications that can be launched using the standard graphical mechanism of a release-blocking desktop after a default installation of that desktop must start successfully and withstand a basic functionality test. 

Basic functionality means that the app must at least be broadly capable of its most basic expected operations, and that it must not crash without user intervention or with only basic user intervention.


Muon is not included by default in Plasma, but Apper is broken beyond repair as per bz#1181859, bz#1177137 and bz#1098735. The goal is to replace apper with muon, but muon does not currently pass the basic functionality test.
Comment 2 Rex Dieter 2015-09-29 14:20:06 EDT
$sudo appstreamcli refresh-index --force --verbose

** (appstreamcli:4294): DEBUG: Unable to determine screenshot service for distribution 'Fedora'. Using the Debian services.
** (appstreamcli:4294): DEBUG: Data did not change, no cache refresh needed.
** (appstreamcli:4294): DEBUG: Forcing refresh anyway.
** (appstreamcli:4294): DEBUG: Refreshing AppStream cache
** (appstreamcli:4294): DEBUG: An unknown component was found: webapp
** (appstreamcli:4294): DEBUG: ASXML-WARNING: Invalid component: [Component::devdocs-io.desktop]> name: Devdocs.io | package:  | summary: Easily view and search developer documentation
** (appstreamcli:4294): DEBUG: Removing old rebuild-dir from previous database rebuild.
** (appstreamcli:4294): DEBUG: Changes committed.
AppStream cache update completed, but some metadata was ignored due to errors.


appstream xapian DB ends up being empty(ish), after poking ximion on irc and debugging...

[13:16] <ximion> it happens because the fedora XML defines the unknown component-type "webapp" (not in the spec), causing the parser to abort


Reassigning to appstream-data
Comment 3 Rex Dieter 2015-09-29 14:21:04 EDT
Oh, nevermind, 

[13:19] <ximion> I know about the webapp thing - the main problem is that "webapp" is so weakly defined and currently specific to GNOME/Epiphany, that it didn't make sense to add to the spec yet


back to appstream
Comment 4 Fedora Update System 2015-09-29 15:00:28 EDT
appstream-0.8.4-3.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-77b834245b
Comment 5 Rex Dieter 2015-09-29 18:29:47 EDT
To clarify comment #1, muon-discover won't replace apper, but supplement it.

muon discover is closer to gnome-software, and a application-center software center

apper is a package manager.

Tentative plans are to ship both.
Comment 6 Fedora Update System 2015-10-01 19:54:04 EDT
appstream-0.8.4-3.fc23, muon-5.4.1-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update muon appstream'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-77b834245b
Comment 7 Fedora Update System 2015-10-01 21:49:53 EDT
appstream-0.8.4-3.fc23, muon-5.4.1-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update muon appstream'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-77b834245b
Comment 8 Adam Williamson 2015-10-05 18:19:53 EDT
Discussed at 2015-10-05 blocker review meeting: https://meetbot-raw.fedoraproject.org/fedora-blocker-review/2015-10-05/f23-blocker-review.2015-10-05-16.00.html . We agreed to delay determination on the status of this bug and request that KDE/Plasma team firm up their plans about what they're going to ship as "the default graphical package manager" (as the criterion states) fairly sharpish, since we're already in post-Beta phase and this kind of thing should be nailed down already.
Comment 9 Fedora Update System 2015-10-07 12:35:46 EDT
appstream-0.8.4-3.fc23, muon-5.4.1-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.