Bug 1267317 - Drag and drop copies instead of moves under Wayland
Drag and drop copies instead of moves under Wayland
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
23
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Milan Crha
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-29 11:40 EDT by Berend De Schouwer
Modified: 2015-09-30 01:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-30 01:13:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 755625 None None None Never

  None (edit)
Description Berend De Schouwer 2015-09-29 11:40:58 EDT
Description of problem:

In evolution, dragging a mail message behaves differently under X11 than Wayland.  Under X11 when dragging a message from the current folder to another folder, the message is moved.  In Wayland the message is copied.

The action is described, in text, at the bottom of the window in the status bar while the action is busy.  Under X11 it writes "Moving messages to folder ... " under Wayland it writes "Copying messages to folder ..."


Version-Release number of selected component (if applicable):

evolution-3.18.0-1.fc23.x86_64


How reproducible:

Every time under Wayland


Steps to Reproduce:

1. Start evolution, with at least one message and at least two folders
2. Select the message
3. Drag the message to the other folder


Actual results:

The message is copied


Expected results:

The message is moved


Additional info:

I wrote "folder" instead of "mailbox" because I generally use subfolders.  I only tested on IMAP, but I tested against different IMAP servers.
Comment 1 Berend De Schouwer 2015-09-29 11:41:58 EDT
Gnome # 755625.  Sorry.  Too many bugzillas
Comment 2 Milan Crha 2015-09-30 01:13:22 EDT
Thanks, let's deal with it upstream [1].

[1] https://bugzilla.gnome.org/show_bug.cgi?id=755625

Note You need to log in before you can comment on or make changes to this bug.