Bug 1267320 - Cloud-init (re)start Docker Daemon
Cloud-init (re)start Docker Daemon
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: cloud-init (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Lars Kellogg-Stedman
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-29 11:49 EDT by Eric Jones
Modified: 2015-09-30 10:34 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-30 09:32:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Jones 2015-09-29 11:49:24 EDT
Description of problem:
cloud-init cannot restart docker daemon, it freezes and will fail to finish.

Version-Release number of selected component (if applicable):
RHEL 7.1
cloud-init 0.7.6

How reproducible:
Every time I run cloud-init script with - systemctl restart docker 
or without the re, it will freeze

Steps to Reproduce:
1. Spin up vm with image of rhel 7.1 with flavor m3.large on https://control.os1.phx2.redhat.com/dashboard and add a basic cloud init script, including - systemctl start docker under runcmd
2. log into the instance and run 'tail -f /var/log/cloud-init.log'

Actual results:
cloud-init freezes and fails to complete

Expected results:
restart/start the docker daemon

Additional info:
there is a github logged issue that is very similar: https://github.com/projectatomic/docker-storage-setup/issues/77

Wanted to make sure this was a highlighted issue as Openshift, as well as containers, are running into this issue.
Comment 2 Lars Kellogg-Stedman 2015-09-29 13:45:36 EDT
Try running:

    systemctl --no-block restart docker

The problem is that docker can't start until cloud-init has finished running, so you've got yourself deadlocked.
Comment 3 Eric Jones 2015-09-29 14:33:31 EDT
That worked. Thank you. Is there any documentation on that?
Comment 4 Lars Kellogg-Stedman 2015-09-30 09:32:25 EDT
> Is there any documentation on that?

Well, there's the systemd documentation, describes the --no-block option:

  http://www.freedesktop.org/software/systemd/man/systemctl.html

It looks like there is a blog post out there on this particular issue:

  http://dustymabe.com/2015/08/03/installingstarting-systemd-services-using-cloud-init/
Comment 5 Eric Jones 2015-09-30 10:34:00 EDT
Okay,

I appreciate it.

Note You need to log in before you can comment on or make changes to this bug.