Bug 1267347 - Provider status displays URI error an SCVMM instance has an ESX host added to the Fabric
Provider status displays URI error an SCVMM instance has an ESX host added to...
Status: CLOSED DUPLICATE of bug 1153706
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers (Show other bugs)
5.5.0
Unspecified Unspecified
medium Severity medium
: GA
: 5.6.0
Assigned To: Bronagh Sorota
Jeff Teehan
scvmm:ems_refresh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-29 13:45 EDT by Jeff Teehan
Modified: 2016-10-03 12:19 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-02-19 08:26:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: Unknown


Attachments (Terms of Use)

  None (edit)
Description Jeff Teehan 2015-09-29 13:45:02 EDT
Description of problem:


Version-5.5.0.2


How reproducible:Always


Steps to Reproduce:
1.  Open SCVMM instance, select Fabric and add a vCenter Server
2.  Click VM tab and add vCenter Cluster as a Host
3.  In appliance, refresh the provider Relationships

Actual results:

In Status:Last Refresh you will see an error message stating the URI (example: "esx-55-01") invalid.

When this occurs, nothing from the provider updates and the provider is unusable.


Expected results:

I don't know if we want to actually manage cross-vendor hosts, but at a minimum it would be nice if we simply ignored it or perhaps placed it in a read-only state.

Additional info:

This takes a while to setup and it disrupts all appliances that use the SCVMM instance, so please contact me (jeff teehan) when you need to reproduce it and I'll get it all setup.  It takes about 10-15 to set it up and another 10 to tear it down.

I don't know how common it is to do this, except that I've always put ESX hosts on my SCVMM instances and my Hyper-V hosts on my vCenter instances so that I could do simple stuff without having to fire up another management system.
Comment 2 Bronagh Sorota 2016-02-19 08:26:08 EST

*** This bug has been marked as a duplicate of bug 1153706 ***

Note You need to log in before you can comment on or make changes to this bug.