Bug 1267348 - Space in deployment name breaks cloudforms install
Space in deployment name breaks cloudforms install
Status: CLOSED CURRENTRELEASE
Product: Red Hat Quickstart Cloud Installer
Classification: Red Hat
Component: Installation - CloudForms (Show other bugs)
1.0
Unspecified Unspecified
medium Severity high
: TP2
: 1.0
Assigned To: David Davis
Dave Johnson
Dan Macpherson
: Triaged
Depends On:
Blocks: rhci-sprint-11 rhci-sprint-12
  Show dependency treegraph
 
Reported: 2015-09-29 14:02 EDT by Sean Myers
Modified: 2016-10-03 15:29 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-10-03 15:29:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sean Myers 2015-09-29 14:02:00 EDT
Description of problem:
I named a deployment "Basic Deployment". The CloudForms install step then failed, because it couldn't bring in a template named "Basic" from the export domain.

Spelunking the logs reveals that the template in question was expected to be named "Basic Deployment-cfme-template", indicating that the space between Basic and Deployment is causing problems.

Version-Release number of selected component (if applicable):
20150829.0 < Somewhat old

How reproducible:
I've made it happen twice in two tries, so 100% so far.

Steps to Reproduce:
1. Deploy the iso, run fusor installer, etc, to get to creating a new deployment
2. Create a new deployment with a space in its name, choosing to deploy cloudforms into rhevm
3. Wait for the deplyoment to fail when setting up CloudForms

Actual results:
Install fails due to template "Basic" not existing in rhevm.

Expected results:
Install succeeds because the expected template exists.

Additional info:
This a rather dated version of the installer, and I haven't tested on a newer version, but I didn't see this reported elsewhere and expect it might be an issue.

I was able to force the installation to continue by adding a template to the export domain named "Basic" and resuming the failed task.
Comment 1 Jason Montleon 2015-12-11 11:56:15 EST
I believe David Davis has a change in so we can labelize the deployment name and use that instead of the deployment names so problems like this don't keep cropping up.
Comment 2 David Davis 2016-01-12 13:48:37 EST
If we want to add a (separate) label field to deployments, we can reuse katello's labelize stuff:

https://github.com/Katello/katello/blob/master/app/models/katello/ext/label_from_name.rb

I don't have any sort of change in though to do this.
Comment 3 Jesus M. Rodriguez 2016-01-13 22:26:29 EST
We put in a temporary fix to disallow deployment names with a space. RHEV doesn't allow templates to have spaces in their names.

https://github.com/fusor/fusor/pull/621
Comment 4 Antonin Pagac 2016-01-26 06:37:15 EST
Deployment name now cannot contain a space character. Marking as verified.

RHCI-6.0-RHEL-7-20160122.t.1-RHCI-x86_64-dvd1.iso

Note You need to log in before you can comment on or make changes to this bug.