Bug 1267353 - TUI doesn't provide an option to enter IPv6 netmask
TUI doesn't provide an option to enter IPv6 netmask
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.2
All Linux
medium Severity medium
: rc
: ---
Assigned To: Samantha N. Bueno
Release Test Team
:
Depends On:
Blocks: 1256306
  Show dependency treegraph
 
Reported: 2015-09-29 14:28 EDT by Jan Stodola
Modified: 2017-02-09 03:56 EST (History)
1 user (show)

See Also:
Fixed In Version: anaconda-21.48.22.75-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-03 19:14:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Stodola 2015-09-29 14:28:50 EDT
Description of problem:
Text UI screen for configuration of network devices doesn't provide an option to enter IPv6 netmask:

================================================================================
Device configuration

 1) IPv4 address or "dhcp" for DHCP
    dhcp
 2) IPv4 netmask
 3) IPv4 gateway
 4) IPv6 address or "auto" for automatic, "dhcp" for DHCP, "ignore" to turn off
    2620:52:0:1068:0:ff:fe00:7
 5) IPv6 default gateway
    2620:52:0:1068::2
 6) Nameservers (comma separated)
 7) [x] Connect automatically after reboot
 8) [ ] Apply configuration in installer
Configuring device ens3.


Version-Release number of selected component (if applicable):
anaconda-21.48.22.50-1.el7
(also anaconda-19.31.123-1.el7, RHEL-7.1 GA)

How reproducible:
always

Steps to Reproduce:
1. start the installation in text mode
2. proceed to the network device configuration screen
3. try to enter a netmask for IPv6

Actual results:
no option for IPv6 netmask

Expected results:
IPv6 netmask option is present

Additional info:
It is possible to enter IPv6 "address" in form address/netmask, but this is not mentioned anywhere.
Comment 2 David Cantrell 2016-01-29 15:15:32 EST
I think the only thing that needs to happen here is to clarify the input expected when it prompts for the IPv6 address.
Comment 7 errata-xmlrpc 2016-11-03 19:14:11 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2158.html

Note You need to log in before you can comment on or make changes to this bug.