Bug 1267377 - Won't launch once installed due to missing gschema xml
Won't launch once installed due to missing gschema xml
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
Unspecified Linux
unspecified Severity high
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-29 16:40 EDT by Hamid Elaosta
Modified: 2015-11-02 21:05 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-02 21:05:42 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Hamid Elaosta 2015-09-29 16:40:54 EDT
Description of problem:

Application won't launch due to missing schema setup on Linux Mint/Ubuntu


Version-Release number of selected component (if applicable):

Git master, revision b45a0ce2867f2ae4fb28c27c31c49dc30175db7b


How reproducible:


Steps to Reproduce:
1. Git clone Virt-Manager
2. Install depencies
3. python setup.py install virt-manager
4. execute "virt-manager"

Actual results:

Debug log shows that start failed due to missing gschema xml

(virt-manager:11567): GLib-GIO-ERROR **: Settings schema 'org.virt-manager.virt-manager' is not installed



Expected results:

virt-manager should launch without error


Additional info:


A previous commit log shows that the install path was recently changed on Ubuntu from /usr/local/share to /usr/share, I don't know whether the schema setup is attempted but fails due to the path change but, the prob can be resolved manually as follows;

WORKAROUND

$ glib-compile-schemas --strict /usr/share/glib-2.0/schemas/
Comment 1 Cole Robinson 2015-11-02 21:05:42 EST
Thanks for the report, fixed upstream now:

commit fe722b99cb386e7f4163f3515b66d69c41f097d2
Author: Cole Robinson <crobinso@redhat.com>
Date:   Mon Nov 2 16:19:31 2015 -0500

    setup: Make gsettings always work regardless of install dir (bz #1267377)

Note You need to log in before you can comment on or make changes to this bug.