Bug 1267399 - SELinux is preventing hp-config_usb_p from 'write' accesses on the directory /root.
Summary: SELinux is preventing hp-config_usb_p from 'write' accesses on the directory ...
Keywords:
Status: CLOSED DUPLICATE of bug 1266903
Alias: None
Product: Fedora
Classification: Fedora
Component: cups
Version: 23
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:53626ddd503fac9980c0e68de53...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-29 23:53 UTC by Martín Cigorraga
Modified: 2015-10-23 14:35 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-10-23 14:35:33 UTC
Type: ---


Attachments (Terms of Use)

Description Martín Cigorraga 2015-09-29 23:53:22 UTC
Description of problem:
Ejected my HP pendrive after waking up from suspend.
SELinux is preventing hp-config_usb_p from 'write' accesses on the directory /root.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that hp-config_usb_p should be allowed write access on the root directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep hp-config_usb_p /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:cupsd_t:s0-s0:c0.c1023
Target Context                system_u:object_r:admin_home_t:s0
Target Objects                /root [ dir ]
Source                        hp-config_usb_p
Source Path                   hp-config_usb_p
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           filesystem-3.2-35.fc23.x86_64
Policy RPM                    selinux-policy-3.13.1-147.fc23.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.2.1-300.fc23.x86_64 #1 SMP Mon
                              Sep 21 22:13:13 UTC 2015 x86_64 x86_64
Alert Count                   1
First Seen                    2015-09-29 20:51:27 ART
Last Seen                     2015-09-29 20:51:27 ART
Local ID                      99f68753-c1c7-43bd-be09-efaa9ab107fa

Raw Audit Messages
type=AVC msg=audit(1443570687.542:634): avc:  denied  { write } for  pid=15410 comm="hp-config_usb_p" name="root" dev="dm-1" ino=100663393 scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:admin_home_t:s0 tclass=dir permissive=0


Hash: hp-config_usb_p,cupsd_t,admin_home_t,dir,write

Version-Release number of selected component:
selinux-policy-3.13.1-147.fc23.noarch

Additional info:
reporter:       libreport-2.6.2
hashmarkername: setroubleshoot
kernel:         4.2.1-300.fc23.x86_64
type:           libreport

Comment 1 Alex Puchades 2015-10-03 19:13:23 UTC
Description of problem:
The error message was shown while plugging my printer for the first time.

Version-Release number of selected component:
selinux-policy-3.13.1-147.fc23.noarch

Additional info:
reporter:       libreport-2.6.2
hashmarkername: setroubleshoot
kernel:         4.2.1-300.fc23.x86_64
type:           libreport

Comment 2 Lukas Vrabec 2015-10-06 13:56:10 UTC
Hi, 

Are you login as root?

Comment 3 Martín Cigorraga 2015-10-06 16:33:59 UTC
Hi Lukas,

In my case I was logged in as usual with my limited user account.

Comment 4 Miroslav Grepl 2015-10-13 08:50:18 UTC
It could be an access check.

Comment 5 Tim Waugh 2015-10-23 14:35:33 UTC

*** This bug has been marked as a duplicate of bug 1266903 ***


Note You need to log in before you can comment on or make changes to this bug.