Bug 1267437 - UI AttributeError break Hosted-Engine deployment via RHEV-H TUI
UI AttributeError break Hosted-Engine deployment via RHEV-H TUI
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node-plugin-hosted-engine (Show other bugs)
3.6.0
Unspecified Unspecified
urgent Severity urgent
: ovirt-3.6.1
: 3.6.1
Assigned To: Ryan Barry
Ying Cui
: AutomationBlocker, Regression, TestBlocker
Depends On:
Blocks: 1144917 1208041 1245143
  Show dependency treegraph
 
Reported: 2015-09-29 23:16 EDT by Ying Cui
Modified: 2016-03-09 09:39 EST (History)
7 users (show)

See Also:
Fixed In Version: ovirt-node-3.3.0-0.14.20151013git5f84da0.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 09:39:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ovirt-node.log (55.95 KB, text/plain)
2015-09-29 23:20 EDT, Ying Cui
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 44004 None None None Never

  None (edit)
Description Ying Cui 2015-09-29 23:16:30 EDT
Description:
 Can not start TUI HE deployment process because of UI AttributeError.

An error appeared in the UI: AttributeError("'TransactionProgressDialog' object has no attribute 'event'",)
Press ENTER to logout ...
or enter 's' to drop to shell


# rpm -q ovirt-node ovirt-hosted-engine-setup
ovirt-node-3.3.0-0.10.20150928gite7ee3f1.el7ev.noarch
ovirt-hosted-engine-setup-1.3.0-1.el7ev.noarch

# cat /etc/redhat-release 
Red Hat Enterprise Virtualization Hypervisor release 7.2 (20150928.0.el7ev)

Test Steps:
1. Installed RHEVH 7.2 (20150928.0.el7ev) for rhev 3.6.0 successful.
2. Setup Network yet
3. Deploy HE on RHEV-H TUI.
4. Enable "PXE Boot Engine VM"
5. Click on "Deploy"

Actual Result:
Can not start HE deployment process, break on UI AttributeError, then have to be back to shell.

Expected Result:
Can start HE deployment process without such error.

# ovirt-node.log
<snip>
2015-09-30 02:48:05,232      ERROR An error appeared in the UI: AttributeError("'TransactionProgressDialog' object has no attribute 'event'",)
2015-09-30 02:48:05,232       INFO Exception:
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/ovirt/node/app.py", line 304, in run
    self.ui.run()
  File "/usr/lib/python2.7/site-packages/ovirt/node/ui/urwid_builder.py", line 441, in run
    self.__loop.run()
  File "/usr/lib64/python2.7/site-packages/urwid/main_loop.py", line 271, in run
    self.screen.run_wrapper(self._run)
  File "/usr/lib64/python2.7/site-packages/urwid/raw_display.py", line 241, in run_wrapper
    return fn()
  File "/usr/lib64/python2.7/site-packages/urwid/main_loop.py", line 336, in _run
    self.event_loop.run()
  File "/usr/lib64/python2.7/site-packages/urwid/main_loop.py", line 707, in run
    self._loop()
  File "/usr/lib64/python2.7/site-packages/urwid/main_loop.py", line 786, in _loop
    self._watch_files[fd]()
  File "/usr/lib64/python2.7/site-packages/urwid/main_loop.py", line 387, in _update
    self.process_input(keys)
  File "/usr/lib64/python2.7/site-packages/urwid/main_loop.py", line 487, in process_input
    k = self._topmost_widget.keypress(self.screen_size, k)
  File "/usr/lib64/python2.7/site-packages/urwid/container.py", line 566, in keypress
    *self.calculate_padding_filler(size, True)), key)
  File "/usr/lib64/python2.7/site-packages/urwid/container.py", line 1559, in keypress
    key = self.focus.keypress(tsize, key)
  File "/usr/lib64/python2.7/site-packages/urwid/container.py", line 2240, in keypress
    key = w.keypress((mc,) + size[1:], key)
  File "/usr/lib64/python2.7/site-packages/urwid/container.py", line 1559, in keypress
    key = self.focus.keypress(tsize, key)
  File "/usr/lib64/python2.7/site-packages/urwid/container.py", line 1559, in keypress
    key = self.focus.keypress(tsize, key)
  File "/usr/lib64/python2.7/site-packages/urwid/decoration.py", line 618, in keypress
    return self._original_widget.keypress(maxvals, key)
  File "/usr/lib64/python2.7/site-packages/urwid/container.py", line 1102, in keypress
    return self.body.keypress( (maxcol, remaining), key )
  File "/usr/lib/python2.7/site-packages/ovirt/node/ui/widgets.py", line 759, in keypress
    return super(TabablePile, self).keypress(size, key)
  File "/usr/lib64/python2.7/site-packages/urwid/container.py", line 1559, in keypress
    key = self.focus.keypress(tsize, key)
  File "/usr/lib64/python2.7/site-packages/urwid/decoration.py", line 833, in keypress
    return self._original_widget.keypress((maxcol,), key)
  File "/usr/lib64/python2.7/site-packages/urwid/container.py", line 2240, in keypress
    key = w.keypress((mc,) + size[1:], key)
  File "/usr/lib64/python2.7/site-packages/urwid/container.py", line 1559, in keypress
    key = self.focus.keypress(tsize, key)
  File "/usr/lib64/python2.7/site-packages/urwid/decoration.py", line 618, in keypress
    return self._original_widget.keypress(maxvals, key)
  File "/usr/lib64/python2.7/site-packages/urwid/wimp.py", line 534, in keypress
    self._emit('click')
  File "/usr/lib64/python2.7/site-packages/urwid/widget.py", line 463, in _emit
    signals.emit_signal(self, name, self, *args)
  File "/usr/lib64/python2.7/site-packages/urwid/signals.py", line 120, in emit
    result |= bool(callback(*args_copy))
  File "/usr/lib/python2.7/site-packages/ovirt/node/ui/widgets.py", line 542, in on_click_cb
    urwid.emit_signal(self, 'click', self)
  File "/usr/lib64/python2.7/site-packages/urwid/signals.py", line 120, in emit
    result |= bool(callback(*args_copy))
  File "/usr/lib/python2.7/site-packages/ovirt/node/ui/urwid_builder.py", line 111, in on_widget_click_cb
    ui_button.on_activate(change)
  File "/usr/lib/python2.7/site-packages/ovirt/node/base.py", line 103, in __call__
    self.emit(userdata)
  File "/usr/lib/python2.7/site-packages/ovirt/node/base.py", line 85, in emit
    if cb(self.target, userdata) is False:
  File "/usr/lib/python2.7/site-packages/ovirt/node/ui/__init__.py", line 201, in __call__
    r = self.callback(userdata)
  File "/usr/lib/python2.7/site-packages/ovirt/node/app.py", line 176, in call_on_ui_save
    self.current_plugin()._on_ui_save()
  File "/usr/lib/python2.7/site-packages/ovirt/node/plugins.py", line 406, in _on_ui_save
    successfull_merge = self.on_merge(effective_changes)
  File "/usr/lib/python2.7/site-packages/ovirt/node/setup/hostedengine/hosted_engine_page.py", line 267, in on_merge
    args=(progress_dialog.event,))
AttributeError: 'TransactionProgressDialog' object has no attribute 'event'
</snip>
Comment 1 Ying Cui 2015-09-29 23:18:44 EDT
No such issue on rhevh 7.2 (20150831.0.el7ev) for 3.6.0.
Comment 2 Ying Cui 2015-09-29 23:20 EDT
Created attachment 1078527 [details]
ovirt-node.log
Comment 5 Ryan Barry 2015-09-30 10:17:33 EDT
This depends on the linked gerrit commit, which doesn't appear to have been merged.
Comment 6 Ying Cui 2015-10-11 22:45:20 EDT
This bug is not included in build rhev-hypervisor7-7.2-20151009.0( ovirt-node-plugin-hosted-engine-0.3.0-1.el7ev.noarch)

So the HE deployment via RHEV-H TUI all test cases still are blocked.
Comment 7 Ying Cui 2015-10-11 22:53:16 EDT
Checked the patch it was in ovirt-node, and merged. (ovirt-node-3.3.0-0.13.20151008git03eefb5.el7ev.noarch)

so need to update the bug status to Assigned to recheck. 

The error on build rhev-hypervisor7-7.2-20151009.0 is _100%_ same as original bug description and log info, so I won't provide new fresh log.
Comment 11 Eyal Edri 2015-11-01 09:26:26 EST
this bug has both 3.5.z & 3.6.0 flags, in bugzilla lang it means its a clone candidate from 3.6.0 to 3.5.z meaning it's pending a clone and wasn't fixed for 3.5.z.

if this isn't the case, please fix flags accordingly,
if it is the case, then please clone the bugs to 3.5.7 (3.5.6 was built already)
Comment 16 errata-xmlrpc 2016-03-09 09:39:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html

Note You need to log in before you can comment on or make changes to this bug.