Bug 1267467 - [rhevh7.2_3.6][node]rescue shell display is not normal on physical machine
Summary: [rhevh7.2_3.6][node]rescue shell display is not normal on physical machine
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: 3.6.0
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: ovirt-3.6.1
: 3.6.0
Assignee: Fabian Deutsch
QA Contact: Huijuan Zhao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-09-30 06:43 UTC by Huijuan Zhao
Modified: 2016-03-09 14:39 UTC (History)
10 users (show)

Fixed In Version: ovirt-node-3.6.1-5.0.el7ev
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-03-09 14:39:43 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)
the screenshot of shell display unnormal (1.53 MB, image/png)
2015-09-30 06:43 UTC, Huijuan Zhao
no flags Details
log (7.02 MB, application/x-gzip)
2015-09-30 06:47 UTC, Huijuan Zhao
no flags Details
shell.png (20.56 KB, image/png)
2015-11-27 04:57 UTC, Ying Cui
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2016:0378 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update for RHEV 3.6 2016-03-09 19:06:36 UTC
oVirt gerrit 46964 master MERGED app: Reset after drop to shell Never
oVirt gerrit 49311 ovirt-3.6 MERGED app: Reset after drop to shell Never

Description Huijuan Zhao 2015-09-30 06:43:22 UTC
Created attachment 1078540 [details]
the screenshot of shell display unnormal

Description of problem:
After login RHEVH TUI, press "F2" to enter rescue shell, rescue shell display is not normal on physical machine (refer attachment)

Version-Release number of selected component (if applicable):
rhev-hypervisor-7-7.2-20150928.0.el7ev
ovirt-node-3.3.0-0.10.20150928gite7ee3f1.el7ev.noarch

How reproducible:
100%

Steps to Reproduce:
1. TUI clean install rhev-hypervisor-7-7.2-20150928.0.el7ev
2. TUI login RHEVH
3. press "F2" to enter rescue shell

Actual results:
after step3, rescue shell display is not normal on physical machine (refer attachment)

Expected results:
after step3, rescue shell display should be normal

Additional info:
no such issue when connect RHEVH via ssh

Comment 1 Huijuan Zhao 2015-09-30 06:47:24 UTC
Created attachment 1078541 [details]
log

Comment 3 Fabian Deutsch 2015-09-30 10:05:52 UTC
Workaround is to run reset or clear once you dropped to shell.

Comment 6 Ying Cui 2015-10-22 10:25:23 UTC
so far RHEV-H build have not been ready to QE although the bug is ON_QA, QE will verify this bug when the build is ready later.

Comment 7 Huijuan Zhao 2015-11-11 02:46:09 UTC
Still encounter this issue on rhev-hypervisor-7-7.2-20151104.0.el7ev.

Version-Release number of selected component (if applicable):
rhev-hypervisor-7-7.2-20151104.0.el7ev
ovirt-node-3.6.0-0.20.20151103git3d3779a.el7ev.noarch

How reproducible:
100%

Test Steps:
1. TUI clean install rhev-hypervisor-7-7.2-20150928.0.el7ev
2. TUI login RHEVH
3. press "F2" to enter rescue shell

Test results:
after step3, rescue shell display is not normal on physical machine (same as attachment " the screenshot of shell display unnormal ")

So I will change the status to ASSIGNED.

Comment 9 Ying Cui 2015-11-27 04:57:42 UTC
Created attachment 1099569 [details]
shell.png

Fabian, we consider to OPEN this bug, we don't officially support F2 to shell, but our customers usually enter to shell to generate sos report or check hosted-engine VM poweroff, check-liveliness etc. or something else.

I attached the screenshot, the display is bad to user.

Comment 13 Huijuan Zhao 2015-12-03 06:55:47 UTC
Version-Release number of selected component (if applicable):
rhev-hypervisor-7-7.2-20151201.1.el7ev
ovirt-node-3.6.0-0.23.20151201git5eed7af.el7ev.noarch

Test steps:
1. Install rhev-hypervisor-7-7.2-20151201.1.el7ev
2. TUI login RHEVH
3. press "F2" to enter rescue shell

Test results:
after step3, rescue shell display normally

So this bug is fixed on rhev-hypervisor-7-7.2-20151201.1.el7ev, I will change the status to verified.

Comment 15 errata-xmlrpc 2016-03-09 14:39:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html


Note You need to log in before you can comment on or make changes to this bug.