Bug 1267470 - Networking is falsely brought up during TUI install of RHEV-H
Networking is falsely brought up during TUI install of RHEV-H
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node (Show other bugs)
3.6.0
Unspecified Unspecified
high Severity urgent
: ovirt-3.6.0-rc3
: 3.6.0
Assigned To: Douglas Schilling Landgraf
Huijuan Zhao
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 02:50 EDT by Huijuan Zhao
Modified: 2016-03-09 09:39 EST (History)
11 users (show)

See Also:
Fixed In Version: ovirt-node-3.3.0-0.18.20151022git82dc52c.el7ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-09 09:39:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Node
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of network unnormal (1.53 MB, image/png)
2015-09-30 02:50 EDT, Huijuan Zhao
no flags Details
log (7.02 MB, application/x-gzip)
2015-09-30 02:52 EDT, Huijuan Zhao
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 47393 master MERGED recipe: RHEVH 7 - disabling NetworkManager Never
oVirt gerrit 47486 ovirt-3.6 MERGED recipe: RHEVH 7 - disabling NetworkManager Never

  None (edit)
Description Huijuan Zhao 2015-09-30 02:50:56 EDT
Created attachment 1078542 [details]
screenshot of network unnormal

Description of problem:
TUI clean install RHEVH, "network" on TUI is disabled and status is unknown, but press "F2" enter to rescue shell, type in "ifconfig", there is ip address, and can ping out successful.
There should be no ip address in rescue shell after TUI clean install.

Version-Release number of selected component (if applicable):
rhev-hypervisor-7-7.2-20150928.0.el7ev
ovirt-node-3.3.0-0.10.20150928gite7ee3f1.el7ev.noarch

How reproducible:
100%


Steps to Reproduce:
1. TUI clean install rhev-hypervisor-7-7.2-20150928.0.el7ev
2. TUI login RHEVH, check "Status" and "Network" on TUI
3. press "F2" to enter rescue shell, type in "ifconfig"

Actual results:
after step2, "Networking" status is unknown, and network is Unconfigured(Disabled).
after step3, there is ip address, and can ping out successful.

Expected results:
after step3, there should be no ip address.

Additional info:
Comment 1 Huijuan Zhao 2015-09-30 02:52 EDT
Created attachment 1078543 [details]
log
Comment 2 Fabian Deutsch 2015-09-30 06:31:08 EDT
It seems that NetworkManager is still available and enabled on RHEV-H and also bringing up unconfigured interfaces.

We should disable it like we tried to do.

Otherwise we can still configure NM to not bring up NICs by default.
Comment 4 cshao 2015-10-12 05:16:33 EDT
Set priority to urgent due to it will affect outcomes of subsequent tests. (e.g. rhevm status - "Managed by: Engine https://XXXX" on the Status page.)
Comment 5 Fabian Deutsch 2015-10-13 02:26:57 EDT
During TUI install the networking should not be brought up (but it is brought up and configured during auto-install).

The fact that the TUI states "unconfigured" after TUI install is correct, and it was like this before.

This is a bug, because by default, the networking of Node should be disabled/unconfigured after auto instal, this includes that it hasn't got an IP address.
However, networking can be configured as usual by configuring a NIC on the network page.

As said in comment 2 we need to make sure that no IP is assigned after TUI install.
Comment 7 Ying Cui 2015-10-13 06:48:55 EDT
Need to add additional info on this bug to make more clear on this bug, or we need to split new bug for this: We set ip on host via TUI, after rhevh reboot, the network status on TUI is unknown as well.

We consider this issue block some test cases checkpoints, example as the following:

1. TUI clean installed rhevh successful.
2. setup network via dhcp.
3. check status TUI, the network status is configured.
4. setup kdump
5. register to rhevm 3.6
6. register to rhn
7. reboot rhevh
8. relogin rhevh
9. check status TUI, the network status is unknown.
10. check kdump 
11. check rhevm 
12. check rhn

then the step 10, 11, and 12 can not be checked with network as unknown.
Comment 8 Huijuan Zhao 2015-11-03 03:55:12 EST
Tested pass on rhev-hypervisor-7-7.2-20151025.0.el7ev

Test version:
rhev-hypervisor-7-7.2-20151025.0.el7ev
ovirt-node-selinux-3.3.0-0.18.20151022git82dc52c.el7ev.noarch

Test Steps:
1. TUI clean install rhev-hypervisor-7-7.2-20151025.0.el7ev
2. TUI login RHEVH, check "Status" and "Network" on TUI
3. press "F2" to enter rescue shell, type in "ifconfig"

Test results:
after step2, "Networking" status is unknown, and network is Unconfigured(Disabled).
after step3, there is no ip address.

So this bug has been fixed on 3.6.0 build, I will change the status to verified.
Comment 10 errata-xmlrpc 2016-03-09 09:39:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0378.html

Note You need to log in before you can comment on or make changes to this bug.