Bug 1267492 - dnf cannot install man-db without tty
dnf cannot install man-db without tty
Status: CLOSED DUPLICATE of bug 1269665
Product: Fedora
Classification: Fedora
Component: dnf (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 03:52 EDT by Lukas Slebodnik
Modified: 2015-10-08 03:24 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-08 03:24:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lukas Slebodnik 2015-09-30 03:52:57 EDT
Description of problem:
There were some problems with using mock on fedora rawhide. It took me a day
to reduce scope of a problem and it seems that bug is in dnf and mock
uses dnf as package_manager on rawhide.

The problem is that dnf is not bale to install package man-db without tty.
Initially I thought it might be caused by rpm because it works on fedora 23
with the same version of dnf. But package man-db can be installed on rawhide
with the latest yum-deprecated and the latest rpm.

Version-Release number of selected component (if applicable):
dnf-1.1.2-3.fc24.noarch
rpm-4.13.0-0.rc1.3.fc24.x86_64

How reproducible:
Deterministic

Steps to Reproduce:
The simplest way is to use docker, but you might test with mock as well
1. docker run \
          --rm fedora:rawhide \
          sh -c "dnf update -y dnf rpm  && dnf install -y man-db" \
   || echo -e "\nFAILED"
 
Actual results:
Tail of log:
Running transaction check
Transaction check succeeded.
Running transaction test
Transaction test succeeded.
Running transaction
  Installing  : groff-base-1.22.3-6.fc23.x86_64                             1/4 
  Installing  : libpipeline-1.4.1-1.fc24.x86_64                             2/4 
warning: libpipeline-1.4.1-1.fc24.x86_64: Header V3 RSA/SHA256 Signature, key ID 81b46521: NOKEY
  Installing  : less-479-3.fc24.x86_64                                      3/4 
warning: less-479-3.fc24.x86_64: Header V3 RSA/SHA256 Signature, key ID 81b46521: NOKEY
warning: man-db-2.7.3-3.fc24.x86_64: Header V3 RSA/SHA256 Signature, key ID 81b46521: NOKEY
  Installing  : man-db-2.7.3-3.fc24.x86_64                                  4/4
FAILED


Expected results:
The package is installed without any problem. 

Additional info:
It works with dnf and tty
sh# docker run --tty \
       --rm fedora:rawhide \
       sh -c "dnf update -y dnf rpm  && dnf install -y man-db" \
    || echo -e "\nFAILED"

Example of log: (tail)
Transaction test succeeded.
Running transaction
  Installing  : groff-base-1.22.3-6.fc23.x86_64                             1/4 
  Installing  : libpipeline-1.4.1-1.fc24.x86_64                             2/4 
warning: libpipeline-1.4.1-1.fc24.x86_64: Header V3 RSA/SHA256 Signature, key ID 81b46521: NOKEY
  Installing  : less-479-3.fc24.x86_64                                      3/4 
warning: less-479-3.fc24.x86_64: Header V3 RSA/SHA256 Signature, key ID 81b46521: NOKEY
warning: man-db-2.7.3-3.fc24.x86_64: Header V3 RSA/SHA256 Signature, key ID 81b46521: NOKEY
  Installing  : man-db-2.7.3-3.fc24.x86_64                                  4/4 
  Verifying   : man-db-2.7.3-3.fc24.x86_64                                  1/4 
  Verifying   : groff-base-1.22.3-6.fc23.x86_64                             2/4 
  Verifying   : less-479-3.fc24.x86_64                                      3/4 
  Verifying   : libpipeline-1.4.1-1.fc24.x86_64                             4/4 

Installed:
  groff-base.x86_64 1.22.3-6.fc23           less.x86_64 479-3.fc24              
  libpipeline.x86_64 1.4.1-1.fc24           man-db.x86_64 2.7.3-3.fc24          

Complete!



It also works with yum-deprecated and without tty
sh# docker run \
           --rm fedora:rawhide \
           sh -c "dnf install -y yum rpm  && yum-deprecated -y install man-db" \
    || echo FAILED

Tail of log:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
  Installing : groff-base-1.22.3-6.fc23.x86_64                              1/4
  Installing : libpipeline-1.4.1-1.fc24.x86_64                              2/4
warning: libpipeline-1.4.1-1.fc24.x86_64: Header V3 RSA/SHA256 Signature, key ID 81b46521: NOKEY
  Installing : less-479-3.fc24.x86_64                                       3/4
warning: less-479-3.fc24.x86_64: Header V3 RSA/SHA256 Signature, key ID 81b46521: NOKEY
warning: man-db-2.7.3-3.fc24.x86_64: Header V3 RSA/SHA256 Signature, key ID 81b46521: NOKEY
  Installing : man-db-2.7.3-3.fc24.x86_64                                   4/4
  Verifying  : groff-base-1.22.3-6.fc23.x86_64                              1/4
  Verifying  : libpipeline-1.4.1-1.fc24.x86_64                              2/4
  Verifying  : less-479-3.fc24.x86_64                                       3/4
  Verifying  : man-db-2.7.3-3.fc24.x86_64                                   4/4

Installed:
  man-db.x86_64 0:2.7.3-3.fc24

Dependency Installed:
  groff-base.x86_64 0:1.22.3-6.fc23           less.x86_64 0:479-3.fc24
  libpipeline.x86_64 0:1.4.1-1.fc24

Complete!
Comment 1 Lukas Slebodnik 2015-09-30 03:54:41 EDT
Adding more verbose output from installation
sh# docker run \
           --rm fedora:rawhide \
           sh -c "dnf update -y dnf rpm  && dnf --rpmverbosity=debug --verbose install -y man-db"

Tail of log:
D: Plugin: calling hook fsm_file_prepare in selinux plugin
D: adding "man-db" to Name index.
D: adding 212 entries to Basenames index.
D: adding "System Environment/Base" to Group index.
D: adding 29 entries to Requirename index.
D: adding 8 entries to Providename index.
D: adding 1 entries to Obsoletename index.
D: adding 88 entries to Dirnames index.
D: adding 1 entries to Installtid index.
D: adding 1 entries to Sigmd5 index.
D: adding "b04abd4f6d675d381a480c1e960e4ad4af544edb" to Sha1header index.
D: adding 2 entries to Transfiletriggername index.
D: %post(man-db-2.7.3-3.fc24.x86_64): scriptlet start
D: %post(man-db-2.7.3-3.fc24.x86_64): execv(/bin/sh) pid 40
D: Plugin: calling hook scriptlet_fork_post in selinux plugin
+ /usr/bin/rm -rf '/var/cache/man/*'
D: %post(man-db-2.7.3-3.fc24.x86_64): waitpid(40) rc 40 status 0
fdio:       6 reads,    51568 total bytes in 0.000025 secs
fdio:       2 writes,       40 total bytes in 0.000048 secs
D: running post-transaction scripts
D:  read h#     171 Header V3 RSA/SHA256 Signature, key ID 34ec9cba: NOKEY
D: unknown: groff-base-1.22.3-6.fc23.x86_64 has 0 files
D: Plugin: calling hook psm_pre in selinux plugin
D:  read h#     172 Header V3 RSA/SHA256 Signature, key ID 81b46521: NOKEY
D: unknown: libpipeline-1.4.1-1.fc24.x86_64 has 0 files
D: Plugin: calling hook psm_pre in selinux plugin
D:  read h#     173 Header V3 RSA/SHA256 Signature, key ID 81b46521: NOKEY
D: unknown: less-479-3.fc24.x86_64 has 0 files
D: Plugin: calling hook psm_pre in selinux plugin
D:  read h#     174 Header V3 RSA/SHA256 Signature, key ID 81b46521: NOKEY
D: unknown: man-db-2.7.3-3.fc24.x86_64 has 0 files
D: Plugin: calling hook psm_pre in selinux plugin
D: %triggerin(man-db-2.7.3-3.fc24.x86_64): scriptlet start
D: %triggerin(man-db-2.7.3-3.fc24.x86_64): execv(/bin/sh) pid 42
D: Plugin: calling hook scriptlet_fork_post in selinux plugin
+ /usr/bin/mandb -q
D: %triggerin(man-db-2.7.3-3.fc24.x86_64): waitpid(42) rc 42 status 0
[root@vm-057 ~]#
Comment 2 Jan Zeleny 2015-10-08 03:24:05 EDT

*** This bug has been marked as a duplicate of bug 1269665 ***

Note You need to log in before you can comment on or make changes to this bug.