This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1267522 - Hostgroup Jail missing access to subscription_manager_configuration_url
Hostgroup Jail missing access to subscription_manager_configuration_url
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.1.2
Unspecified Unspecified
unspecified Severity medium (vote)
: Beta
: --
Assigned To: Stephen Benjamin
jcallaha
http://projects.theforeman.org/issues...
: Triaged
Depends On: 1126087
Blocks: 1122832
  Show dependency treegraph
 
Reported: 2015-09-30 05:31 EDT by Peter Vreman
Modified: 2016-07-27 05:19 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 05:19:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 12177 None None None 2016-04-22 12:15 EDT

  None (edit)
Description Peter Vreman 2015-09-30 05:31:46 EDT
Description of problem:
The hostgroup provisioning templates are missing the subscription_manager_configuration_url. This is used by the susbcription-manager templates. The host templates have this method available

Below is the small patch to add it also to the hostgroup jail:

# diff -u /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.67/app/models/katello/concerns/hostgroup_extensions.rb.old /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.67/app/models/katello/concerns/hostgroup_extensions.rb
--- /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.67/app/models/katello/concerns/hostgroup_extensions.rb.old   2015-09-29 09:00:51.666132841 +0000
+++ /opt/rh/ruby193/root/usr/share/gems/gems/katello-2.2.0.67/app/models/katello/concerns/hostgroup_extensions.rb       2015-09-29 09:01:31.429921126 +0000
@@ -87,5 +87,5 @@
 end

 class ::Hostgroup::Jail < Safemode::Jail
-  allow :content_source, :rhsm_organization_label
+  allow :content_source, :subscription_manager_configuration_url, :rhsm_organization_label
 end


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Use subscription-manager snippet in hostgroup template
2.
3.

Actual results:
Missing or not empty output for a call to subscription_manager_configuration_url from the template

Expected results:
subscription_manager_configuration_url is replaced with the url

Additional info:
Comment 2 Stephen Benjamin 2015-10-15 08:00:00 EDT
Created redmine issue http://projects.theforeman.org/issues/12177 from this bug
Comment 3 Bryan Kearney 2015-10-15 08:00:46 EDT
Upstream bug component is Content Management
Comment 4 Bryan Kearney 2015-10-16 16:00:49 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/12177 has been closed
-------------
Anonymous
Applied in changeset commit:katello|05046a3b2c3d26b1c23e4cd2826e10667fe3d290.
Comment 5 Tazim Kolhar 2015-12-18 05:31:36 EST
Currently in upstream, we cannot create hostgroup
thanks
Comment 9 jcallaha 2016-07-19 16:53:38 EDT
Verified in Satellite 6.2 Beta Snap 20.2.

No issues encountered when using the subscription_manager_registration provisioning template.
Comment 11 errata-xmlrpc 2016-07-27 05:19:31 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.