Bug 1267524 - spice-server can bind/listen at non-existent IPv4 address
spice-server can bind/listen at non-existent IPv4 address
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Default Assignee for SPICE Bugs
SPICE QE bug list
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 05:40 EDT by Andrei Stepanov
Modified: 2015-10-05 12:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-05 12:09:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrei Stepanov 2015-09-30 05:40:33 EDT
rpm -qf /usr/lib64/libspice-server.so.1.8.0                                                                                  
spice-server-0.12.4-9.el7_1.1.x86_64

The problem is:
spice-server accepts parameter: addr=<some digital num>
It starts listen at non-existent address:

# /usr/libexec/qemu-kvm -spice disable-ticketing,port=3000,addr=6756756


# ss -l -t -n 'sport = :3000'

Local Address:Port
0.103.25.148:3000

Expected behavior: 
spice-server should check existence of the specified address before bind to it.


More example:

/usr/libexec/qemu-kvm -spice disable-ticketing,port=3000,addr=0.1
Local Address:Port
0.0.0.1:3000
Comment 2 Frediano Ziglio 2015-10-05 12:09:28 EDT
First class A range is for self identification so the address you mentioned are perfectly valid. See https://tools.ietf.org/html/rfc6890.

Note You need to log in before you can comment on or make changes to this bug.