Bug 1267537 - ksh hangs when executed in from removed directory
ksh hangs when executed in from removed directory
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ksh (Show other bugs)
7.0
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: Michal Hlavinka
Jan Kepler
: EasyFix, Patch, Regression, Reproducer, ZStream
Depends On: 1204639
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 07:01 EDT by Jan Kurik
Modified: 2015-12-01 09:59 EST (History)
10 users (show)

See Also:
Fixed In Version: ksh-20120801-22.el7_1.3
Doc Type: Bug Fix
Doc Text:
Previously, when the KSH shell was executed from a removed directory, the code responsible for detection of current working directory could get stuck in an infinite loop. A patch has been applied to fix this bug, and the shell no longer becomes unresponsive in this situation.
Story Points: ---
Clone Of: 1204639
Environment:
Last Closed: 2015-11-04 10:50:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Kurik 2015-09-30 07:01:50 EDT
This bug has been copied from bug #1204639 and has been proposed
to be backported to 7.1 z-stream (EUS).
Comment 8 errata-xmlrpc 2015-11-04 10:50:29 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1967.html

Note You need to log in before you can comment on or make changes to this bug.