Bug 1267540 - Missing requirement on otopi >= 1.4.0
Missing requirement on otopi >= 1.4.0
Product: ovirt-engine
Classification: oVirt
Component: Packaging.rpm (Show other bugs)
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ovirt-3.6.0-ga
: 3.6.0
Assigned To: Sandro Bonazzola
Petr Matyáš
: Automation
Depends On:
  Show dependency treegraph
Reported: 2015-09-30 07:09 EDT by Sandro Bonazzola
Modified: 2015-11-04 06:43 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2015-11-04 06:43:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
rule-engine: exception+
sherold: planning_ack+
sbonazzo: devel_ack+
pnovotny: testing_ack+

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46842 master MERGED packaging: spec: fix otopi requirements Never
oVirt gerrit 46843 ovirt-engine-3.6 MERGED packaging: spec: fix otopi requirements Never
oVirt gerrit 46844 ovirt-engine-3.6.0 MERGED packaging: spec: fix otopi requirements Never

  None (edit)
Description Sandro Bonazzola 2015-09-30 07:09:15 EDT
Since a requirement on otopi >= 1.3.2 is in place, without a yum update ovirt-engine-3.6.0 can be installed with otopi-1.3.2 failing the setup with:

[ ERROR ] Failed to execute stage 'Environment setup': type object 'BaseEnv' has no attribute 'EXIT_CODE'

otopi-1.4.0 is required.

Detected by jenkins: http://jenkins.ovirt.org/job/ovirt-engine_master_upgrade-from-master_el7_merged/518/console

Not marking as blocker since 'yum update "otopi*"' solve the issue.
Comment 1 Sandro Bonazzola 2015-11-04 06:43:32 EST
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.

Note You need to log in before you can comment on or make changes to this bug.