Bug 1267545 - trace raised when provising from catalog with JSON parser error
trace raised when provising from catalog with JSON parser error
Status: CLOSED ERRATA
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Provisioning (Show other bugs)
5.4.0
Unspecified Unspecified
unspecified Severity medium
: GA
: 5.6.0
Assigned To: Daniel Berger
Shveta
catalog:provision
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 07:30 EDT by Felix Dewaleyne
Modified: 2016-06-29 10:59 EDT (History)
9 users (show)

See Also:
Fixed In Version: 5.6.0.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-29 10:59:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
trace.log (2.75 KB, text/plain)
2015-09-30 07:30 EDT, Felix Dewaleyne
no flags Details
cloning.patch (744 bytes, patch)
2015-09-30 07:33 EDT, Felix Dewaleyne
no flags Details | Diff

  None (edit)
Description Felix Dewaleyne 2015-09-30 07:30:25 EDT
Created attachment 1078599 [details]
trace.log

Description of problem:
During a deployment from catalog against an Hyper-V SP1 provider we get

MIQ(MiqProvisionMicrosoft#provision_error) [[JSON::ParserError]: A JSON text must at least contain two octets!] encountered during phase [start_clone_task]

(see trace.log for full trace)

Version-Release number of selected component (if applicable):
cfme-5.4.2.0-1.el6cf.x86_64

How reproducible:
on customer site, reproduced multiple times

Steps to Reproduce:
1. configure a catalog item to deply a vm by cloning
2. initiate the provision of the catalog item
3.

Actual results:
MIQ(MiqProvisionMicrosoft#provision_error) [[JSON::ParserError]: A JSON text must at least contain two octets!] encountered during phase [start_clone_task]

Expected results:
provision passes with no trace

Additional info:
- hyper V Sp1
Comment 2 Felix Dewaleyne 2015-09-30 07:33 EDT
Created attachment 1078600 [details]
cloning.patch

patch against cfme-5.4.2.0-1.el6cf.x86_64's /var/www/miq/vmdb/app/models/miq_provision_microsoft/cloning.rb provided to the customer by Nick Catling
Comment 6 Greg Blomquist 2016-01-27 18:35:51 EST
The customer case is closed, can we close this BZ?
Comment 10 Daniel Berger 2016-04-04 09:55:47 EDT
https://github.com/ManageIQ/manageiq/pull/7688
Comment 11 Shveta 2016-04-18 19:01:04 EDT
Tried provisioning with a template that has space in its name as suggested by Greg B.

No error seen .
Verified in 5.6.0.1-beta2.20160413141124_e25ac0e
Comment 13 errata-xmlrpc 2016-06-29 10:59:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1348

Note You need to log in before you can comment on or make changes to this bug.