Bug 1267559 - oc export imagestream always fails(Upstream issue - https://github.com/openshift/origin/issues/3924)
oc export imagestream always fails(Upstream issue - https://github.com/opensh...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
3.0.0
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Michail Kargakis
Wei Sun
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 08:08 EDT by Miheer Salunke
Modified: 2015-11-23 09:26 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 09:26:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Origin (Github) 3924 None None None Never

  None (edit)
Description Miheer Salunke 2015-09-30 08:08:17 EDT
Description of problem:

Upstream issue - https://github.com/openshift/origin/issues/3924

When creating a template from existing project using this command:

oc export dc,is,se,route --all -o yaml --as-template=hello-php > test-hello-php.yaml

We get panic: assignment to entry in nil map. The export imagestream part fails.

$ oc export is --all -o yaml
panic: assignment to entry in nil map

Version-Release number of selected component (if applicable):
3.0

How reproducible:
Always

Steps to Reproduce:
1.$ oc export svc,ImageStreams,dc --all -o json

2.
3.

Actual results:

It gives an error while exporting resources

Expected results:
It shall do export of resources properly

Additional info:
Comment 2 Michail Kargakis 2015-10-15 14:10:17 EDT
This has been solved as of 1.0.4 in Origin (v3.0.1.900 in OSE)
Comment 3 Xingxing Xia 2015-10-15 22:34:19 EDT
Verified against version:
oc v3.0.2.0-17-g701346b
kubernetes v1.1.0-alpha.0-1605-g44c91b1

The issue is fixed.
Comment 4 Brenton Leanhardt 2015-11-23 09:26:24 EST
This fix is available in OpenShift Enterprise 3.1.

Note You need to log in before you can comment on or make changes to this bug.