Bug 1267585 - Filter within Activation Keys -> Host Collections only works on visible host collections
Filter within Activation Keys -> Host Collections only works on visible host ...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.1.2
Unspecified Unspecified
unspecified Severity medium (vote)
: GA
: --
Assigned To: Brad Buckingham
Roman Plevka
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks: 1317008
  Show dependency treegraph
 
Reported: 2015-09-30 09:24 EDT by Stuart Auchterlonie
Modified: 2016-07-27 07:25 EDT (History)
3 users (show)

See Also:
Fixed In Version: rubygem-katello-3.0.0.26-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:25:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
host-collection list (40.25 KB, image/png)
2016-06-27 03:49 EDT, Roman Plevka
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 2162211 None None None 2016-02-15 11:55 EST
Foreman Issue Tracker 14120 None None None 2016-04-26 13:10 EDT

  None (edit)
Description Stuart Auchterlonie 2015-09-30 09:24:20 EDT
Description of problem:

When trying to assign a host collection to an activation key,
if you have a large number of host collections (such that there
are multiple pages of host collections), you would use a filter
to try to quickly find the host collection you are after.

However the filter only works on the items which are currently
visible. You first have to scroll to the part of the list which
contains the host collection you are interested in, and then the
filter will find it.

This defeats the purpose of the filter

Version-Release number of selected component (if applicable):

Sat 6.1.2

How reproducible:

100%

Steps to Reproduce:
1. Create a large number of host collections
2. Create an activation key
3. Select the Host Collections tab, then the add tab
4. Put in a filter which should select a host collection
   which is not on the currently visible page

Actual results:

Host collection is not found, as the filter is only applied
to the visible page, not the whole list

Expected results:

The whole list of host collections is filtered and only the
matching host collections are shown.

Additional info:
Comment 2 Brad Buckingham 2016-03-09 09:32:31 EST
Created redmine issue http://projects.theforeman.org/issues/14120 from this bug
Comment 3 Brad Buckingham 2016-03-09 09:35:26 EST
Upstream katello PR: https://github.com/Katello/katello/pull/5862
Comment 4 Bryan Kearney 2016-03-09 10:02:14 EST
Upstream bug component is Content Management
Comment 5 Bryan Kearney 2016-03-15 22:02:10 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14120 has been closed
-------------
Brad Buckingham
Applied in changeset commit:katello|cbc79a620c9fa665bee30a8bd4bc25a7df836b2e.
Comment 6 Roman Plevka 2016-06-27 03:49 EDT
Created attachment 1172793 [details]
host-collection list

VERIFIED
on sat6.2.0 beta (GA17.0)

The form now displays full list, thus the filtering works globally.
Comment 7 Bryan Kearney 2016-07-27 07:25:44 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.