Bug 1267594 - anaconda crash in "reclaim disk space" panel for lvm partitions (f23 beta RC1)
anaconda crash in "reclaim disk space" panel for lvm partitions (f23 beta RC1)
Status: CLOSED DUPLICATE of bug 1245423
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
23
ppc64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F23PPCFinal
  Show dependency treegraph
 
Reported: 2015-09-30 09:52 EDT by Menanteau Guy
Modified: 2015-10-22 12:06 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-06 15:46:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot of "reclaim disk space" panel (35.61 KB, image/png)
2015-09-30 09:52 EDT, Menanteau Guy
no flags Details
anaconda.log (21.96 KB, text/plain)
2015-09-30 09:53 EDT, Menanteau Guy
no flags Details
anaconda tb log (709.79 KB, text/plain)
2015-09-30 09:54 EDT, Menanteau Guy
no flags Details
storage log (225.31 KB, text/plain)
2015-09-30 09:55 EDT, Menanteau Guy
no flags Details
syslog (216.40 KB, text/plain)
2015-09-30 09:56 EDT, Menanteau Guy
no flags Details

  None (edit)
Description Menanteau Guy 2015-09-30 09:52:38 EDT
Created attachment 1078658 [details]
screen shot of "reclaim disk space" panel

anaconda crash in "reclaim disk space" panel for lvm partitions (f23 ppc64 beta RC1) 
I did following test on ppc64 bare metal.

Three steps test.
First step, install of f23 ppc64 (lvm scheme) using little disk space
- use "Manual partitioning" " to remove all existing partitions
- then use "Click here to create them automatically) " to create new partitions
- then change /home size partitions to 20 GB and update
- run the install

Second step, install of f23 ppc64 (lvm scheme) using the rest of disk space
- use " " to create patitions of second install
- run the install

At this time we have:
[anaconda root@furax ~]# fdisk -l
Disk /dev/sda: 264.3 GiB, 283794997248 bytes, 554287104 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xfb8cca42

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1  *         2048     10239      8192     4M 41 PPC PReP Boot
/dev/sda2           10240   1034239   1024000   500M 83 Linux
/dev/sda3         1034240 156229631 155195392    74G 8e Linux LVM
/dev/sda4       156229632 554287103 398057472 189.8G  5 Extended
/dev/sda5       156231680 157255679   1024000   500M 83 Linux
/dev/sda6       157257728 554287103 397029376 189.3G 8e Linux LVM


Third step, delete partitions of first install to do new install
- I try to remove partitions of first install automatically using "Reclaim Disk Space" 
problem is triggering at this time by a click on one of /boot partitions listed 
in "Reclaim Disk Space" panel.
Comment 1 Menanteau Guy 2015-09-30 09:53 EDT
Created attachment 1078660 [details]
anaconda.log
Comment 2 Menanteau Guy 2015-09-30 09:54 EDT
Created attachment 1078661 [details]
anaconda tb log
Comment 3 Menanteau Guy 2015-09-30 09:55 EDT
Created attachment 1078662 [details]
storage log
Comment 4 Menanteau Guy 2015-09-30 09:56 EDT
Created attachment 1078663 [details]
syslog
Comment 5 David Shea 2015-10-06 15:46:11 EDT

*** This bug has been marked as a duplicate of bug 1245423 ***
Comment 6 Ngo Than 2015-10-14 05:26:27 EDT
i tested the Fedora-Server-DVD-ppc64-23_TC1 image on ppc64 several times and cannot reproduce this issue anymore. I confirm that the issue is fixed in the latest image.
Comment 7 Menanteau Guy 2015-10-22 12:06:17 EDT
I confirm this problem cannot be reproduced with TC1 image.

Note You need to log in before you can comment on or make changes to this bug.