Bug 1267603 - kmailservice5 ignores email client settings
kmailservice5 ignores email client settings
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kf5-kio (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: KDE SIG
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 10:03 EDT by Karel Volný
Modified: 2016-06-07 10:33 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-07 10:33:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karel Volný 2015-09-30 10:03:25 EDT
Description of problem:
I've set up my email client to trojitá. Yet kmailservice5 still results to kmail.

Version-Release number of selected component (if applicable):
kf5-kio-core-5.14.0-2.fc23.x86_64

How reproducible:
always (I mean each run of kmailservice5)

Steps to Reproduce:
1. change your default email client to something else than kmail
2. $ cat .config/emaildefaults
3. $ /bin/kmailservice5 mailto:test@example.com

Actual results:
$ cat .config/emaildefaults                                                                                                                                                                   
[Defaults]                                                                                                                                                                                                     
Profile=Výchozí                                                                                                                                                                                                
                                                                                                                                                                                                               
[PROFILE_Výchozí]                                                                                                                                                                                              
EmailClient[$e]=/bin/trojita                                                                                                                                                                                   
ServerType=                                                                                                                                                                                                    
TerminalClient=false

$ /bin/kmailservice5 mailto:test@example.com
$ Legacy integer arithmetics implementation 
kmail2(30242): No language dictionaries for the language :  "cs" 

kmail2(30242): No language dictionaries for the language :  "cs" 

kmail2(30242): No language dictionaries for the language :  "cs" 

kmail2(30242): No language dictionaries for the language :  "cs" 

 ~StorageServiceJobConfigPrivate

(kmail message editor window appears)

Expected results:
(trojitá message editor windows appears)

Additional info:
I'm not exactly sure if I've rebooted (relogged-in) since the change in SystemSettings, as I've done it some time ago and only today tried to use kmailservice. However, I don't think I should need that, such change should apply immediately within the running session, just like changes in mimetype associations and similar.
Comment 1 Rex Dieter 2015-09-30 11:56:14 EDT
I think the problem here is that kmailservice5 tries the x-scheme-handler/mailto mimetype default, which probably is still kmail.
Comment 2 Rex Dieter 2015-09-30 11:58:38 EDT
This should have fixed it, but I'm not seeing it,

https://git.reviewboard.kde.org/r/120569/
Comment 3 Rex Dieter 2015-09-30 12:04:59 EDT
Looks like that came after plasma-5.4.1 release, my bad
Comment 4 Karel Volný 2015-10-01 07:30:35 EDT
(In reply to Rex Dieter from comment #1)
> I think the problem here is that kmailservice5 tries the
> x-scheme-handler/mailto mimetype default, which probably is still kmail.

so, does that mean that this setting obsoletes emaildefaults?

or that it has to be set in both places at once and all the configuration tools allowing to change one of them must be aware about it and mirror the change to the second place? - er, where do I even set x-scheme-handler if it is not under Associoations tab in systemsettings?
Comment 5 Rex Dieter 2015-10-01 08:22:45 EDT
Partially obsoleted yes, as I mentioned, the reviewboard reference from comment #2 should fix this (included in plasma-5.4.2 release coming any day now)
Comment 7 Rex Dieter 2016-06-07 10:33:28 EDT
Turns out kmailservice5 was deprecated/removed in kf5-5.22.0 release

Note You need to log in before you can comment on or make changes to this bug.