Bug 1267628 - [PATCH] Include Appstream metadata for thunderbird-enigmail
[PATCH] Include Appstream metadata for thunderbird-enigmail
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: thunderbird-enigmail (Show other bugs)
23
All Linux
unspecified Severity medium
: ---
: ---
Assigned To: Christian Dersch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 10:21 EDT by Stephen Gallagher
Modified: 2016-01-13 01:24 EST (History)
2 users (show)

See Also:
Fixed In Version: thunderbird-enigmail-1.8.2-4.fc23 thunderbird-enigmail-1.8.2-4.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-13 00:22:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Add Appstream metadata (3.47 KB, patch)
2015-09-30 10:21 EDT, Stephen Gallagher
no flags Details | Diff
Add Appstream metadata (3.47 KB, patch)
2015-09-30 10:28 EDT, Stephen Gallagher
sgallagh: review? (fedora)
Details | Diff

  None (edit)
Description Stephen Gallagher 2015-09-30 10:21:58 EDT
Created attachment 1078670 [details]
Add Appstream metadata

Description of problem:
GNOME Software should display Enigmail as an add-on for Thunderbird.

Version-Release number of selected component (if applicable):
thunderbird-enigmail-1.8.2-3.fc23.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Launch GNOME Software
2. Go to the "Email" section
3. Look at the Thunderbird entry

Actual results:
Thunderbird only displays Adblock Plus and HTTPS Anywhere

Expected results:
Thunderbird should also display Enigmail as an available add-on


Additional info:
Patch attached to this bug adds the necessary Appstream data. Please commit it to the repository or respond with a reason not to. If I do not get a response within one week (give or take), I will simply commit and build as a provenpackager.
Comment 1 Stephen Gallagher 2015-09-30 10:28 EDT
Created attachment 1078672 [details]
Add Appstream metadata

Obsoleting original patch. Bad copy-paste error meant that the URL for the homepage was wrong. This version corrects that.
Comment 2 Remi Collet 2015-09-30 10:42:28 EDT
As this is not upstreamable, I reluctant to apply such change.

Really, we should find another solution.
This file have no value to be "IN" the package, not used.
Comment 3 Stephen Gallagher 2015-09-30 11:19:39 EDT
(In reply to Remi Collet from comment #2)
> As this is not upstreamable, I reluctant to apply such change.
>

It is only useful for the downstream distribution. Such things belong therefore in their downstream packages.
 
> Really, we should find another solution.
> This file have no value to be "IN" the package, not used.

It actually *is* used in the package. It's used to inform GNOME Software of the installed state of the add-on.
Comment 4 Richard Hughes 2015-10-01 09:04:33 EDT
(In reply to Remi Collet from comment #2)
> As this is not upstreamable, I reluctant to apply such change.

Sure, it's upstreamable, and lots of upstream projects have included them upstream. I'm sure Stephen would be amiable to relicencing to something else if that's the upstream concern. Upstream is also best place long term as the project can translate the file for us too, and saves opensuse and arch patching in something almost quite the same.

> Really, we should find another solution.

Well, downstream makes it work for Fedora 23, and means that enigmail gets more prominence and certainly more users. Quite a lot of packages first shipped the metainfo file downstream, and when there was an upstream release with a new tarball then the downstream file was trivially deleted. I'm totally an "upstream first" kinda guy, but I'm also the person who wants to see Fedora 23 look awesome.

Richard.
Comment 5 Stephen Gallagher 2015-12-21 09:25:28 EST
Remi, could you perhaps reconsider the inclusion of this metadata file? There's been a recent push[1] to start getting more add-ons included into GNOME Software, and I'd like to be able to land this.

Obviously, the ideal situation would be for this to go upstream, but you would know better than I whether they would accept this metadata there. If not, please incorporate it in the spec file as we really have no other place to store this information.

[1] https://lists.fedoraproject.org/archives/list/desktop%40lists.fedoraproject.org/thread/DHHIVNYV7JASLTHH4CMTXUAJSJLEPPF4/
Comment 6 Jiri Eischmann 2015-12-21 12:01:02 EST
Adding the appstream metafiles to packages is strongly recommended in our packaging guidelines [1]. I think it provides pretty strong guidance in questioning whether the file should or should not be in the package. Not mentioning it's really useful for users because it makes the extension much more discoverable.

[1] https://fedoraproject.org/wiki/Packaging:AppData
Comment 7 Remi Collet 2015-12-27 05:12:57 EST
Sorry, but I don't plan to apply this.

I really think a non localized, and non managed by upstream file doesn't make sense.

I'm rather thinking to add a soft dep. so the package will be installed by default with Thunderbird, thus dropping the need for this file.

Feel free to ask upstream to include it in their sources repo.
Comment 8 Stephen Gallagher 2016-01-04 08:26:26 EST
A soft dependency still doesn't completely solve the problem, since if a user ends up installing Thunderbird through some mechanism that doesn't support Recommends: (such as yum-deprecated), there would still be no mechanism by which GNOME Software (or any other AppStream-aware software manager) could display the available add-on. Also, it's frowned upon to use reverse deps (such as Supplements:); if you're going this route, it's better to coordinate with the Thunderbird maintainer and have it be a Recommends: in that package. (Otherwise you are probably going to surprise them with having this default changed).

I'm really not sure why you are so vehemently against including this. If it's just about localization, the AppStream data *can* be localized; I just only speak one language. If you want me to Google Translate it into a few additional languages, I can do that...

One responsibility of a Fedora package maintainer is to handle cases where Fedora packaging guidelines require differences from upstream. Our guidelines say that GUI add-ons are supposed to have AppStream data (the only reason it's a "should" rather than "must" statement is because we agreed not to force all applications to update at once). So please apply this patch as a temporary measure. If you feel that this is best managed upstream, then by all means please contact upstream. You are the better person to do this as you are already a part of that community.
Comment 9 Fedora Admin XMLRPC Client 2016-01-04 08:40:59 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 10 Christian Dersch 2016-01-04 10:24:38 EST
I applied the patch now as it improves user experience and I don't see any obstacles.
Comment 11 Fedora Update System 2016-01-04 10:28:08 EST
thunderbird-enigmail-1.8.2-4.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-c4b763efcf
Comment 12 Fedora Update System 2016-01-04 10:32:08 EST
thunderbird-enigmail-1.8.2-4.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-867d876625
Comment 13 Fedora Update System 2016-01-04 15:51:43 EST
thunderbird-enigmail-1.8.2-4.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-867d876625
Comment 14 Fedora Update System 2016-01-04 15:52:54 EST
thunderbird-enigmail-1.8.2-4.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-c4b763efcf
Comment 15 Fedora Update System 2016-01-13 00:22:13 EST
thunderbird-enigmail-1.8.2-4.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2016-01-13 01:24:12 EST
thunderbird-enigmail-1.8.2-4.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.