Bug 1267631 - Subversion plugin fails to install
Subversion plugin fails to install
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: jenkins (Show other bugs)
23
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Michal Srb
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-09-30 10:27 EDT by Paul Fee
Modified: 2015-10-16 02:58 EDT (History)
3 users (show)

See Also:
Fixed In Version: jenkins-1.625-2.fc23 jenkins-1.609.3-2.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-11 12:04:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Fee 2015-09-30 10:27:55 EDT
Description of problem:
After installing subversion plugin, Jenkins fails to restart.


Version-Release number of selected component (if applicable):
jenkins-1.616-7.fc23.noarch


How reproducible:
Always


Steps to Reproduce:
1. Install F23 server (beta) from ISO.
2. # dnf upgrade
3. # dnf install jenkins
4. # systemctl start jenkins
5. # firewall-cmd --add-port=8080/tcp
6. Point web browser at machine:8080
7. Manage Jenkins/Manager Plugins/Available tab, select "Subversion Plug-in", click "Download now and install after restart".
8. Click "Restart Jenkins when installation is complete and no jobs are running".

Actual results:
Jenkins Web UI reports "Please wait while Jenkins is restarting...", however it never restarts.

Expected results:
Jenkins should restart and subversion options should be available in Source Code Management section when configuring new Jenkins jobs.

Additional info:

The /var/log/jenkins/jenkins.log file contains:
----------------
Sep 30, 2015 2:16:23 PM hudson.model.UpdateCenter doSafeRestart
INFO: Scheduling Jenkins reboot
Sep 30, 2015 2:16:23 PM jenkins.model.Jenkins$23 run
INFO: Restart in 10 seconds
Sep 30, 2015 2:16:33 PM jenkins.model.Jenkins$23 run
SEVERE: Restarting VM as requested by anonymous
Sep 30, 2015 2:16:34 PM org.eclipse.jetty.util.log.JavaUtilLog info
INFO: jetty-8.1.17.v20150415
Sep 30, 2015 2:16:37 PM org.eclipse.jetty.util.log.JavaUtilLog info
INFO: NO JSP Support for , did not find org.apache.jasper.servlet.JspServlet
Jenkins home directory: /var/lib/jenkins found at: System.getProperty("JENKINS_HOME")
Sep 30, 2015 2:16:38 PM org.eclipse.jetty.util.log.JavaUtilLog info
INFO: Started SelectChannelConnector@0.0.0.0:8080
Sep 30, 2015 2:16:38 PM winstone.Logger logInternal
INFO: Winstone Servlet Engine v2.0 running: controlPort=disabled
Sep 30, 2015 2:16:39 PM jenkins.InitReactorRunner$1 onAttained
INFO: Started initialization
----------------


The problem is that Jenkins never fully starts up.  Jenkins service status is:

-----------
$ systemctl status jenkins
● jenkins.service - Jenkins continuous build server
   Loaded: loaded (/usr/lib/systemd/system/jenkins.service; disabled; vendor preset: disabled)
   Active: active (running) since Wed 2015-09-30 14:12:21 BST; 5min ago
  Process: 1595 ExecStart=/usr/libexec/jenkins/jenkins start (code=exited, status=0/SUCCESS)
 Main PID: 1650 (java)
   CGroup: /system.slice/jenkins.service
           ├─1650 /etc/alternatives/java -Djava.awt.headless=true -DJENKINS_HOME=/var/lib/jenkins -cp /usr/share/jenkins/webroot//:/usr/share/jen...
           └─1815 /usr/bin/unzip -d /var/lib/jenkins/plugins/subversion /var/lib/jenkins/plugins/subversion.jpi -x 'WEB-INF/classes/*'

Sep 30 14:12:21 bel1wkl252.tycofs.com systemd[1]: Starting Jenkins continuous build server...
Sep 30 14:12:21 bel1wkl252.tycofs.com runuser[1638]: pam_unix(runuser:session): session opened for user jenkins by (uid=0)
Sep 30 14:12:21 bel1wkl252.tycofs.com jenkins[1595]: Starting Jenkins [  OK  ]
Sep 30 14:12:21 bel1wkl252.tycofs.com systemd[1]: Started Jenkins continuous build server.
-----------

It looks like the unzip command has stalled (PID 1815).

strace shows no activity, it outputs just one line, suggesting unzip is not doing any other work.
------------
$ sudo strace -fp 1815 -s 1024
Process 1815 attached
write(1, "  inflating: /var/lib/jenkins/plugins/subversion/WEB-INF/classes/hudson/scm/UserProvidedCredential$1.class  ", 108
------------

File descriptor 4 in PID 1815 matches the stdout message from strace:
-------
# lsof -p 1815
COMMAND  PID    USER   FD   TYPE DEVICE  SIZE/OFF     NODE NAME
unzip   1815 jenkins  cwd    DIR  253,0       224       96 /
unzip   1815 jenkins  rtd    DIR  253,0       224       96 /
unzip   1815 jenkins  txt    REG  253,0    189568   223584 /usr/bin/unzip
unzip   1815 jenkins  mem    REG  253,0 110439344 34033327 /usr/lib/locale/locale-archive
unzip   1815 jenkins  mem    REG  253,0   2102288 33806178 /usr/lib64/libc-2.22.so
unzip   1815 jenkins  mem    REG  253,0     67464 33588201 /usr/lib64/libbz2.so.1.0.6
unzip   1815 jenkins  mem    REG  253,0    160248 33804091 /usr/lib64/ld-2.22.so
unzip   1815 jenkins  mem    REG  253,0     26254 34033306 /usr/lib64/gconv/gconv-modules.cache
unzip   1815 jenkins    0r  FIFO   0,10       0t0    51590 pipe
unzip   1815 jenkins    1w  FIFO   0,10       0t0    51591 pipe
unzip   1815 jenkins    2w  FIFO   0,10       0t0    51592 pipe
unzip   1815 jenkins    3r   REG  253,0   7210574 34253426 /var/lib/jenkins/plugins/subversion.jpi
unzip   1815 jenkins    4u   REG  253,0         0 67691353 /var/lib/jenkins/plugins/subversion/WEB-INF/classes/hudson/scm/UserProvidedCredential$1.class
--------

The file in question exists but has no bytes written:
-------
# ls -l /var/lib/jenkins/plugins/subversion/WEB-INF/classes/hudson/scm/UserProvidedCredential*
-rw-r--r--. 1 jenkins jenkins    0 Sep 30 14:16 /var/lib/jenkins/plugins/subversion/WEB-INF/classes/hudson/scm/UserProvidedCredential$1.class
-rw-r--r--. 1 jenkins jenkins 6184 Sep  7 14:13 /var/lib/jenkins/plugins/subversion/WEB-INF/classes/hudson/scm/UserProvidedCredential$AuthenticationManagerImpl.class
-rw-r--r--. 1 jenkins jenkins 4805 Sep  7 14:13 /var/lib/jenkins/plugins/subversion/WEB-INF/classes/hudson/scm/UserProvidedCredential.class
-------

I've been using Jenkins (jenkins-1.590-3.fc21.noarch) successfully on Fedora 21 and didn't encounter this problem.  It's not obvious to me whether this is a Fedora packaging issue or an upstream Jenkins bug.

Let me know if I can help with additional information.
Comment 1 Michal Srb 2015-10-01 01:02:00 EDT
Thanks for the bug report Paul. I suspect this is a packaging issue on our side. I will look into it.
Comment 2 Fedora Update System 2015-10-02 06:21:41 EDT
jenkins-1.625-2.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2015-b76713a3c1
Comment 3 Michal Srb 2015-10-02 06:56:17 EDT
The same problem is also in Fedora 22, I will prepare an update.
Comment 4 Paul Fee 2015-10-02 10:21:12 EDT
jenkins-1.625-2.fc23 has fixed the problem.  Thank you!
Comment 5 Fedora Update System 2015-10-03 21:52:30 EDT
jenkins-1.625-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update jenkins'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-b76713a3c1
Comment 6 Fedora Update System 2015-10-05 04:00:02 EDT
jenkins-1.609.3-2.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2015-c8aa832fe7
Comment 7 Fedora Update System 2015-10-05 21:08:08 EDT
jenkins-1.609.3-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
If you want to test the update, you can install it with
$ su -c 'dnf --enablerepo=updates-testing update jenkins'
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-c8aa832fe7
Comment 8 Fedora Update System 2015-10-11 12:04:43 EDT
jenkins-1.625-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2015-10-16 02:58:05 EDT
jenkins-1.609.3-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.